Can't connect to router...plz help!

i reflesh openwrt fireware to linksys wrt24g

after i wrote my id and pw to interface->lan->pppope

i can't connect to the router

the led is flash, but can't enter

anyway to fix?

Try to login via SSH using IPv4/IPv6, otherwise go to failsafe&reset:

You should configure pppoe to the WAN interface, not the LAN.
Reset to defaults and configure it again.

1 Like
  1. i tried win10 & mac ssh, can't connect
    ping,can't connect router is Linksys WRT54G
it's on the list
but i visit here
Recovery method can't visit

i just wrote the wrong, it's no way to going back????

First try to press and hold the reset button, while the device is working. Hold it until the LEDs start blinking and then go off. That should be up to 15 seconds of keeping the reset button pressed.

If this doesn't work, try this: Assign static IP to your PC and start a ping ping -t . Remove power, press and hold the reset button, plug in the power and wait for replies from the router. Once you get replies release the reset button and put the firmware by TFTP.

1."Hold it until the LEDs start blinking and then go off. "
power led?

seems i hold the reset as long as i can, but none led blink,when router is woking.....

i can just ping now

according to method blow,i can enter to fail mode, but can't visit web and can't use tftp to refresh the firmware

what can i do next?

Boot into failsafe mode

  1. Unplug the router's power cord.
  2. Connect the router's LAN1 port directly to your PC.
  3. Configure your PC with a static IP address between and ...
  4. Plug the power on and wait for the DMZ LED to light up.

There is something wrong with this link.

Since ping is working, try to telnet or ssh the router.
Otherwise try to send the image with tftp directly.

1 Like

I literally just had a major struggle converting a WRT54GL to OpenWrt.

  • What version of OpenWrt did you flash to this router?

You likely ran out of memory and flash space.


already saved

but i can't find mac filter in this firmware...


  • version 10 is quite old
  • connecting this device to the Internet with version 10 installed is a security risk
  • please answer my other question

We need to know exactly how much flash and memory your device has. The reason is due to this:

Also, if it helps:

  • my WRT54GL became quite slow and unresponsive a few minutes after boot, especially if I attempted to browse to the web GUI. I had to stop the web GUI and some other unneeded processes to get enough stability
  • I could not use sysupgrade to flash the router, I had to use the mtd command. Running suysupgrade often crashed the router.

Use telnet on version 10!

wrg 54g v3

thx 4 u help
i already solved it.
but this version is too slow and i can't find where is mac filter
so i consider to refresh back to dd-wrt than i used before.

3.0 Broadcom BCM4712 @ 216 MHz 16 MB 4 MB CDF8

OK, this device is not suggested for use with OpenWrt.

It would be slow - your device was already 5+ years old when version 10 was released. The MAC filter should be under the Wireless security options for the SSID.

i google
my firmware doesn't has mac filter, maybe too old
forget it
thx all the same.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.