Can't connect to ONT (modem) admin interface through openwrt router

Hi,
I am running OpenWrt 19.07.0-rc1 on a Linksys WRT32X and I am trying to connect to my Optical Network Terminal (a Huawei HG8240H5).
The ONT's IP is 192.168.100.1 and if I connect my desktop pc directly and set my ip to e.g. 192.168.100.67 I can connect just fine. Now I am trying to do the same with the router inbetween.
I have been following these guides explaining how to set up a new interface with a static ip


My router's LAN interface is IPv4: 192.168.1.1/24
My modem, as said, is 192.168.100.1
So I created a new interface:

config interface 'modem'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.100.65'
        option ifname 'eth1.2'

and adjusted my firewall settings for the wan zone accordingly

        option network 'wan wan6 modem'

like the guides explain.
However, I still cannot connect to 192.168.100.1. When I ssh into the router I cannot ping 192.168.100.1 either. So it looks like I am still missing something? Where can I find logs that could explain what is going on?

edit:
for some reason nmap finds the host but I cannot connect to it in any way

Starting Nmap 7.70 ( https://nmap.org ) at 2019-11-24 17:56 +08
Nmap scan report for 192.168.100.1
Host is up (0.00070s latency).
MAC Address: 44:00:4D:25:35:E4 (Unknown)
Nmap scan report for 192.168.100.65
Host is up.
Nmap done: 256 IP addresses (2 hosts up) scanned in 7.84 seconds

I believe this might be your issue, your modem needs to "listen" to VLAN2 otherwise it will ignore these packets....

In other words, your modem's management interface might be using a different VLAN tag, or none at all.
Try this instead:

        option ifname 'eth1'

Is this the same device you use in your WAN interface? Should be the same.

Do you see anything if you run this on the router?

ifconfig | grep 192.168.100.65

Your config looks correct. Can you check if there is a route to the modem?

route

Hi, thanks a lot for the replies. It was indeed the wrong interface.
eth1.2 is my wan switch vlan so i thought I would need to pick that. but 'br-wan' works fine!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.