Cant access to failsafe mode ssh

Hello community,

I had openwrt running with luci on my AVM Fritzbox 4040. So when I started to set it up, i setup some interfaces and firewalls. Now i found a new tutorial to set up more stuff openwrt is used to be known and makes it a great firmware.

I set the lan interface to static ip.

But here comes the thing:

I set my lan to a new IP and pressed enter.

Of course from now I couldnt reach it of the webbrowser again an after the counter ran down it asked me to save the the new settings.

So i started to log on with the new ip, but i doesnt work.

I tried with failsafe (what i can see with the blink7ng code). But i cant access by ssh.

I downloaded the AVM recovering tool and its also not working. When i set up the pc with some other network settings it had found it, but it says it has some other software issues and stops.

What can I do from now. I dont know how to do next step. Anybody knows.

Thanks allot.


Welcome to the community!

How to reset a router to factory defaults

Step 1: Find the reset button.

There should be a tiny reset button. Usually this button is located at the back of the router.

Step 2: Push the reset button.

While the router is on, push and hold the reset button. You will probably need a paper clip to do this, because the button is usually recessed.

Step 3: Hold the reset button.

Continue to push in and hold the reset button for at least 30 seconds.

Step 4: Reboot the router.

Disconnect the power from the router for a few seconds. When you reconnect the power, the router should reboot.

Fritz!Box 4040 has no reset button.

No safe mode no tftpd?

To be clear, the reset procedure offered by @ZebraOnPC does not apply to OpenWrt -- it may apply to some vendor's factory firmware, though.

In the case of the Fritzbox running it's vendor firmware, theoretically there is a "forgot password" option that will allow you to factory reset the device. There is some additional info here and here.

If you're running OpenWrt, typically the WPS button can be used to enter failsafe... apply power an then repeatedly press the button until you see a rapidly flashing LED (I don't know which one, but it should be obvious). If that doesn't work, there appears to be another button ("wifi") on the 4040, so try that one. From there, you can follow the link that @lleachii provided earlier.


Thanks until here. But i dont have issues to start in failsafe mode.

So when its booted and blinked in failsafe mode I cant go any further.

I tried to enter via linux terminal. Nor via windows cmd i can access to root@

Which futher steps resolve that?

Did you:

  • connect your computer to the device via ethernet (wifi will not be available)?
  • set your computer's IP address manually to (subnet mask
  • turn off all other network interfaces on the computer (disable wifi, unplug any other ethernet connections if there is more than one port)?
  • make sure that the only connection to the fritzbox (aside from power) is the single ethernet connection that goes to your computer?
  • run a ping test to
  • ssh root@ ?
1 Like

Headed back to the pc.

Nope, there is no wifi.

My ethernet settings on windows are:

Ip adress
Nothing else.

When i enter cmd and ping it twlls me the target host is not reachable. On putty it says me connection time....

Oh, my.

Ive done it. I just first time entered failsafe. Just didnt recognized im not.

So the "Info" Led is blinking nervously and I had no issues to enter via putty. Its the "Wps" button.

Thank you for your time.

Thanks all helped me here.

Niw I have to find the lan settings and just change em back to my old Ip. Then i should work like it did before?

you'll find that in /etc/config/network and you can use the vi text editor to fix it.

Or if you need to do a full reset, you can do that by issuing:

firstboot -y && reboot

Thank you very much, I had to choose the second option. But it worked well for me. Now i can start from beginning and do things properly.

Have a nice evening!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.