Can't access router to upgrade

Hello experts,

The back story:

I have (I think) a ver of 18. xx installed on a Linksys WRT 1900 AC 1.
When the ver 21.xx stable was announced, I started to notice my wifi signal grow weak and sites running video and even my Google Drive would stop in mid-task.

Also, we have had several electrical storms lately, and some years ago, I witnessed them cause a power brown-out which in turn rendered my Linksys software u/s. Hence I moved to OpenWRT.

Today the wifi signal problem worsened. Ironically I delayed the upgrade as I'm job hunting and feared messing with the software could go awry, leaving me without any access as I troubleshoot for days.

When the first weak signals began, I checked with my ISP and did all the usual power cycling of the modem and router.

My wifi still allows me to send you this, stream music, and browse, but interview software, or hi-res video, for example, is buggy.

I'm using a 2020 model Pixelbook Go.

I have limited Linux terminal experience; by that, I mean every step would have to be outlined; I know I can't safely follow the instructions on here to upgrade via the terminal as they assume a level of familiarity with the terminal commands I don't possess. I have played around with versions of Linux Mint a few years back so I'm not a total novice, but still can't follow the instructions supplied in the upgrade announcement with confidence, I know what I don't know!

I know my Luci IP address is correct as I saved successful prior logins to bookmarks.

I'm ethernet connected via a Rapoo USB/cable hub.

My Pixelbook is running the latest software update as of today. Diagnostics all pass their test

I run Express VPN as an app, not in the router, and toggle on or off doesn't seem to make much difference, but for the upgrade, I'll keep it off.

The Problem:

I can't access the Luci interface online; I get an error connection timeout.

My router display lights are not "normal" in that my internet connection led is usually set by me to glow steady amber; it briefly runs amber on a successful powerup cycle then goes to the factory default of blue. For what that's worth.

I've downloaded the latest stable ver. OpenWRT .img file for my router model to the pixelbook.

I am using auto name servers, switching to Google was unsuccessful, so I reverted to the settings that served me well until recently. I can't see what they are, but IIRC, they're Cloudflare or maybe my VPN providers? The shows me an IP of rather than a style config at that button.

Earlier my connectivity diagnostics showed my DNS settings error left and right. After a restart they're stable again!

But my Google services show "video conferencing" has "TCP request failures", and I still can't see the Luci log in page online.

Thanks for seeing this epic tale through to the end.


When I encounter such situations and I just want to try to get back to any semblance of normalcy, I do the OpenWRT factory reset process using the reset button on my Linksys (1900acs v1 for me). Beware you will lose all your configuration/customizations but it might be the quickest way to get Luci back to the way it was when you originally flashed OpenWrt. Sometimes it's a bit of a challenge to press & hold the reset button at the proper time to get this process going as documented.

Just my opinion

1 Like

Thanks for the quick reply! I don't want this to be the answer, but you could be right. The reason for my reluctance is that I'm presuming a factory reset and starting over would be more time consuming than the upgrade, but maybe not?
Time really is the thing that's most against me. I already had to postpone a promising interview today because of this issue. I had considered a fresh start too, but I'm holding out for a few more hours here before I nuke it. If I do, I will mark the issue solved. Thanks tho, your suggestion is still an option if the login to the current software remains elusive.

A factory reset would generally take 5-10min from start to finish. It will just put you back to the base configuration of the OpenWrt version that you last flashed.

If you absolutely need solid internet for an interview, you could just plug your computer directly into your modem but that has huge security implications as your PC would be totally exposed to the internet during that time.

1 Like

By the way, your Luci IP should be your Gateway IP.

1 Like

I think I'm going to go with your initial suggestion. There is barely any customisation of my setup, this software out the box keeps me happy enough. I might be more diligent with future upgrades tho. I will keep the thread open until I get back to normal, just in case...

I thought the Google OS bypasses any user or network DNS and uses their encrypted servers directly.

I did the reset, noted the gateway had reverted to whereas my Luci was and the Linksys page came up right away. I'm going to mark this solved and just install the upgrade as a new install from the appropriate link for that. Thanks, mortac8

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.