Cannot use PPTP connections after update to 18.06.1

After update kernel to

|Firmware Version|OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)|
|Kernel Version|4.9.120|

I cannot connect to Work-VPN (PPTP) with error 806.
(If i use another router, i can connect)

I think you misunderstood my posting here. You didn't need to make a new thread for this, you needed to make one for the USB.

This is very similar to your previous topic.

In any case:

  • Did you install kmod-nf-nathelper-extra?

Sorry. May be i not understood.

Yes, I installed package kmod-nf-nathelper-extra
but it doesn't help.

In old version OpenWrt I can estabilished one VPN connection.
In last version OpenWrt i can't estabilished VPN connection at all.

Excellent, next step - have you added:

iptables -A PREROUTING -t raw -p tcp --dport 1723 -j CT --helper pptp

root@OpenWrt:~# iptables -A PREROUTING -t raw -p tcp --dport 1723 -j CT --helper pptp
iptables v1.6.2: can't initialize iptables table `raw': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.

Odd...I have a RAW table in 18.06.1.

  • You did install 18.06.1, correct?
  • Is this a custom firmware?
  • Install kmod-ipt-raw

Thank you..
Now it's all right.

root@OpenWrt:~# opkg install kmod-ipt-raw
Installing kmod-ipt-raw (4.9.120-1) to root...
Configuring kmod-ipt-raw.

root@OpenWrt:~# opkg list | grep kmod-ipt-raw
kmod-ipt-raw - 4.9.120-1 - Netfilter IPv4 raw table support
kmod-ipt-raw6 - 4.9.120-1 - Netfilter IPv6 raw table support

root@OpenWrt:~# iptables -A PREROUTING -t raw -p tcp --dport 1723 -j CT --helper pptp

Multiple connects to VPN are success.

1 Like

@mutate If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You can also mark the reply that solved your problem:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.