Cannot ping google or bing successful

just return bad address when I ping google or bing.image

And my network setting is:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd2f:8797:5d69::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

can't understand where is wrong

traceroute openwrt.org
traceroute6 openwrt.org
ip a; ip -4 r; ip -4 ru; ip -6 r; ip -6 ru
head -n -0 /etc/resolv.* /tmp/resolv.*
4 Likes

Can you ping 172.217.18.46 or 204.79.197.200?

3 Likes

connection time out.
image

ifstatus wan
ifstatus wan6
4 Likes

@Hegabo @vgaetera First, I need to thank you guys. Yesterday I can't saw and can't found out the 'Reply' button. I can saw @vgaetera edited him answer twice times. But I can't send any personal message to you I'm so hopeless . I used the openwrt two night and found it's not as stable as official fireware. So tonight I flash back to the official fireware. Thank you guys again. Have a nice day!

supplement two pictures . It's yesterday night snipping, but I can't found out the 'Reply' button. so sucks.

Capture2

The problem here is revealed that your upstream "WAN" network (likely the LAN side of a modem / router) is 192.168.1.1, which conflicts with the LAN in OpenWrt. That makes it impossible to route anything to the Internet. The other firmware is likely using 192.168.0.1 as the LAN, which will work.

2 Likes

You could try changing the IP of your OpenWrt router to 192.168.2.1 for example and give it a one more try.

uci set network.lan.ipaddr="192.168.2.1"
service network restart
uci commit network
2 Likes