Cannot Install the stock FW for EA8500!

I installed this OpenWrt FW because I wanted better QoS which may reduce my problem with the internet buffer, but as stupid as always, I didn't even read any tutorial or figured out if I understand OW FW!

after installation I have HUGE connectivity issues and after like 5 hrs of troubleshooting I just want my internet back and my routers original Firmware. so I downloaded the OEM stock FW from here:
https://openwrt.org/toh/linksys/linksys_ea8500

then went to the router settings >> Backup / Flash Firmware >> Under Flash new firmware image I unchecked keep settings and chose the FW I downloaded (FW_EA8500_1.1.4.169978_prod.img) >> clicked on flash image but this message showed up:
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

please help! what should I do?!!!

@Stoopid, welcome to the community!

OK..the instructions don't tell you to do that.

Have you seen the instructions for your device on the Wiki at:

https://openwrt.org/toh/linksys/linksys_ea8500#going_back_to_linksys_firmwareflashing_back_to_stock

It gives very different directions than what you described.

1 Like

Thank you so much for your reply.. I know I shouldn't have mingled with the FW since I've 0 understanding in any sorts of programming or tech related common sense. I read this:

You will need SSH access to the device as Web UI flashing page will reject stock firmware. You will also need version 1.1.4.169978 of the stock firmware and not anything later (like 1.1.5.178908). Upload the stock firmware file to /tmp/ directory on the router and then run: sysupgrade -n -v -F /tmp/FW_EA8500_1.1.4.169978_prod .

I remembered the SSH thingy under the administrations settings and did this:

but I have no clue what is SSH or how to upload to /tmp/ file! :frowning:


  • You connect via SSH
  • You cd to /tmp
  • Then wget the file to download it
  • Then run command in Wiki
  • Done!
1 Like

thank you so much for helping me, really cannot stress how thankful I'm.

I downloaded (PuTTY) for windows and I reached this step:

but what is cd to /tmp? sorry for my ignorance

You didn't read the 2 manual pages!

From: http://linuxcommand.org/lc3_man_pages/cdh.html

DESCRIPTION
Change the shell working directory.

Change the current directory to DIR.  The default DIR is the value of the
HOME shell variable.
root@OpenWrt:~# cd /tmp/
root@OpenWrt:/tmp#

Any other questions?

1 Like

Thank you lleachii for your effort and most importantly your patience. I take the full responsibility for my stupidity and impulsive behavior towards the router, since I acquire (((( 0 )))) understanding or comprehensive of programming I shouldn't have changed the FW! like literally never open cmd before but to ipconfig and that's it! I read the pages but it made 0 sense to me! :frowning:

now I reached: root@OpenWrt:/tmp#
how can I upload the firmware on it?

Ummmm...

  • Are you having issues with the wget command? (the manual is there too)
  • You're only one step away from the command on the wiki...
1 Like

IK :frowning:

but bare with me here, you say: * Then wget the file to download it

how can I wget the file? I really don't understand this step! :frowning:

Screenshot%20from%202019-05-23%2014-22-28

EXAMPLE if URL is http://example.com/file.bin:

root@OpenWrt:~# cd /tmp/
root@OpenWrt:/tmp# wget http://example.com/file.bin
root@OpenWrt:/tmp# sysupgrade -n -v -F /tmp/file.bin

This should contain everything you need. Hope this helps.

1 Like

now I understand what you wanted me to do, put the link after the word wget and press enter! but...
there is a problem, the whole idea of reverting to stock is because the router (EA8500 with OW FW) failed to connect to the internet! the router connected to zhone fiber modem then the internet, windows icon shows I'm connected to the internet! but only this page opens and thats it!!! if i restart the router it allow me to open any page but this last for like 1-2 sec then I can't anymore. so logically when I tried to download the FW thru the command it said:

rroot@OpenWrt:/tmp# wget http://cache-www.belkin.com/support/dl/FW_EA8500_1.1.4.1
69978_prod.img
Downloading 'http://cache-www.belkin.com/support/dl/FW_EA8500_1.1.4.169978_prod.img'
Failed to establish connection

I have the file on my PC already, is there a way to upload it manually? since the router cannot connect to the internet?

Yes, e.g. via pscp/ scp.

That said, if you just installed OpenWrt once and never updated it to another version, the easiest way to revert back to Linksys' OEM stock firmware might be exploiting its dual-boot feature (invoking three failed boots to make it fail over to the old OEM firmware), see the wiki page for details.

2 Likes

Are you telling me you can only navigate to forum.openwrt.org????

You can try to reset the router if you mean that you edited the defaults:

root@OpenWrt:~# firstboot
root@OpenWrt:~# reboot

BTW, the router should connect to the Internet after flashing OpenWrt, no interaction should be required.

  • You could place it in the backup restore file in /etc/config
  • As @slh noted - you can use pscp/scp.
  • It was also noted your device has a dual parititon, you can force it over to the 2nd
    • After using this method and booting OEM, you should flash the OEM firmware TWICE to remove OpenWrt
1 Like

thank you so much for trying to help. just a reminder I've 0 knowlgne in these things. when I clicked on pscp it take me to the program Im using called putty, does that mean I can use putty to manually upload the FW from my PC to the router?

and about invoking three boot: I wen to this wiki:
https://openwrt.org/toh/linksys/linksys_ea8500#going_back_to_linksys_firmwareflashing_back_to_stock

but didn't find anything about how I invoke the boot? if you don't mind me can you tell me how to do it since I only flashed the OW FW only once. thanks in advance and I totally understand if this too much to ask for.

YUP!!!!!!!!! only this website! freaking strange stuff! I wasted the whoooole day TS with no luck!

I did it from inside the OW itself reset it so many times and did hard reset from the button behind the router.. is it enough?

can you tell me more about: You could place it in the backup restore file in /etc/config if you dont mind?
or how to force the 2nd?

I'll be honest, I'm starting to mind.

This is so much like opening a ZIP file on Windows, I have no clue how to describe anything more in this regard.

You were told already:

You really must start following the directions and instructions that are provided to you.

Why would you look in the going back to firmware section for how to go to the backup on 3 failed boots???

Hopefully someone with this or a similar model can help with step-by-step on the partitions; because all I can tell you is you must invoke 3 failed boots. I'm not understanding the communication issue, sorry.

no worries at all thank you so much for the help.

appreciate you cynicism.

already know you wont answer but since you're trying to help, I'll try to help you to understand my understanding! lets see here: "invoking three failed boots" how can a person invoke the boot? never ever invoked a boot before, is it a line we write to make it boot then invoke it? idk?

English is my third language, I really didnt understand this sentence: "Why would you look in the going back to firmware section"?

no sorry needed. you tried to help but I couldn't figure it out. thank you so much for everything.

1 Like

Just stop it....try count to 5...if not, try count to 6....if not, try count to 10....if not...so on...do it 3 times. On 4th boot, you should have the other parition.

There's an app you can install on OpenWrt to just hit a button; but you don't have Internet to install it.

root@OpenWrt:~# opkg update
root@OpenWrt:~# opkg install luci-app-advanced-reboot

Hope this helps.

EDIT: If you inform us of what your first language is, we can use a translator.