Cannot install package wpad

hello :slight_smile:
i need help urgently :frowning: . im trying to install wpad or wpad-openssl on a TL-WDR4300 with OpenWrt 18.06.5 .
i tried several ways like trying to install online and even offline .

  • first, i tried opkg update then opkg remove wpad-mini and opkg install wpad` . but updating gave me error "Signature check failed!". then i tried opkg install usign and got msg "installed and uptodate!". Then i deactivated option check_signature 1 in opkg.conf and then i could update with opkg update.
  • i tried opkg install wpad` but no way. No success! Error= "Cannot install package!"
  • i tried to give manually the path to https:/...../wpad_2018-05-21-62566bc2-8_mipsel_24kc.ipk (or without ".ipk"), but again same error.
  • i dowloaded that wpad .ipk file and even wpad-openssl and uploaded to /tmp/ in router and tried to install offline from that path, but again "Cannot install package!"

Now i have no idea more and i cant understand, why i get opkg update successfully, but those wpad packages wont be downloaded or updated from .../mips_24kc/wpad... .
What am i doing wrong or why other users can just install wpad normally and i cant do it even offline !!!!!????
my last errors:

root@OpenWrt:~# opkg install /tmp/wpad_2018-05-21-62566bc2-8_mips_24kc.ipk
Collected errors:
 * wfopen: /tmp/wpad_2018-05-21-62566bc2-8_mips_24kc.ipk: No such file or directory.
 * pkg_init_from_file: Failed to extract control file from /tmp/wpad_2018-05-21-62566bc2-8_mips_24kc.ipk

root@OpenWrt:~# opkg install /tmp/wpad_2018-05-21-62566bc2-8_mips_24kc
Unknown package '/tmp/wpad_2018-05-21-62566bc2-8_mips_24kc'.
Collected errors:
 * opkg_install_cmd: Cannot install package /tmp/wpad_2018-05-21-62566bc2-8_mips_24kc.

TP-Link TL-WDR4300 v1.6
using WinSCP and PuTTY

i will appreciate any helping answer :slight_smile:

What is the output of the following?

mount ; df ; cat /etc/opkg.conf ; cat /etc/opkg/*.conf

root@OpenWrt:~# mount ; df ; cat /etc/opkg.conf ; cat /etc/opkg/*.conf
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/up              per,workdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2560      2560         0 100% /rom
tmpfs                    62624       528     62096   1% /tmp
/dev/mtdblock3            4288       312      3976   7% /overlay
overlayfs:/overlay        4288       312      3976   7% /
tmpfs                      512         0       512   0% /dev
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
#option check_signature 1# add your custom package feeds here
# src/gz example_feed_name
src/gz openwrt_core              /generic/packages
src/gz openwrt_kmods              x/generic/kmods/4.9.198-1-2b8f9dfe583e5c09aadd9474da55137f
src/gz openwrt_base              24kc/base
src/gz openwrt_luci              24kc/luci
src/gz openwrt_packages              ips_24kc/packages
src/gz openwrt_routing              ps_24kc/routing
src/gz openwrt_telephony              mips_24kc/telephony

but i must say: i have written # before "option check_signature 1" just to disable it. i had deleted it but now i put # in front of it. i dont know, if i just can change 1-->0 to make it false? just as info.

Yes, and better to use the values if you are not sure, otherwise when commented it might use the default value.

It's rather weird problem. I have router with the same arch ar71xx and it was installed just fine in 18.06.4.
But it is also worrying me that opkg was not able to read the .ipk file from /tmp

If there is no better idea, I'd suggest backup and reset to defaults. Then setup internet connectivity, immediately remove wpad-mini, install wpad, and continue with restoring the backup.

1 Like

very annoying problem. First check_signature failure and then not recognizing ipk file!

  • should i go down to 18.06.4 ? if yes, how to downgrade and find previous builds?
  • i dont exactly understand what do you mean about restoring? i have done several times firstboot -y and then connected to my wifi (internet) and then removed wpad-mini and tried to install wpad, but "package can not install" !!!!!!!!! it seems that it finds the wpad.ipk in internet (check_signature disabled) but doesnt install it. i cant even install wpad-mini after removing it, same error "cannot install package" !!!!!! what a shittttty luck. bought a good router with enough ram and rom but now just a unexplainable stupid problem. just frustrated!
    thx @trendy :slight_smile:

Give it a try. Just flash the router with the 18.06.4 and don't keep settings.
By restoring I meant restoring from backup, the same page as flashing the router.

installed 18.06.4.
again same problems:

  1. check_signature failed! ---> then i deleted option check_signature 1 and updated list successfully.
  2. tried to install wpad but again same error: "cannot install package"

so strange and frustrating! no developer or admin here to analyze this problem!?!?!?!

finally got it working. but every installation was manually. updating online is still an issue!

root@OpenWrt:~# opkg install /tmp/wpad_2018-05-21-62566bc2-8_mips_24kc.ipk
Installing wpad (2018-05-21-62566bc2-8) to root...
Configuring wpad.

thx dear @trendy

I didn't do much actually.
However it sounds very weird that 2 fresh installations of different versions of OpenWrt have problems with signatures. I hope that your provider/state is not doing any nasty stuff.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.