Cannot install nor update packages

Every time I try to update my packages or install a new one I get this error even tho I am connected to the internet I have tired searching for an solution but I couldn’t find one.
Any help would be grateful thank you

What is the output of this command when you run it on the router?
ping -c 4
Also post the outputs of these commands
cat /tmp/resolv*
cat /etc/hosts

Copy the text from the Putty and Paste it here, don't post photos!!!

1 Like

Hi this is what i got,

ping: bad address ''

root@OpenWrt:~# cat /tmp/resolv*
search lan

root@OpenWrt:~# cat /etc/hosts localhost

::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

looks like you don't have a functional internet connection from the OpenWrt router.

Post the following info for more info:

and also describe how the device is connected to the rest of your network.


Also post here the following:

ip -4 addr
ip -4 ro
1 Like
root@OpenWrt:~# vi /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd6a:9924:116f::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'a'
        option tone 'av'

config interface 'lan'
        option type 'bridge'
root@OpenWrt:~# vi /etc/config/firewall
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
- /etc/config/firewall 1/195 0%

i have it connected to a main router as I want to use that router as a vpn router and have my main router just be normal so its simply just connected through an ethernet cable to the main router

root@OpenWrt:~# ip -4 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    inet scope host lo
       valid_lft forever preferred_lft forever
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet brd scope global br-lan
       valid_lft forever preferred_lft forever

root@OpenWrt:~# ip -4 ro dev br-lan scope link  src

Since this is configured as a LAN only device (no WAN), you need to make sure you've specified the gateway and the DNS for your network -- most likely


I changed those setting and i have got it to update without any errors, thank you so much

1 Like

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).



This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.