Cannot get router to work (tp-link archer c2)

Hello, I have a TP-Link Archer C2 V1 router, tried to flash openwrt but something about the tftp server probably messed this up... Now I can't access web interface, only power led turns on (internet led is up for 1 sec then shuts off). Reset won't work. Even 30-30-30 rule. Tried to tftp a firmware again, no luck. Soldered the serial connection and tried to debrick with an arduino, and putty, no luck. Any ideas?

No such thing.

This? -

Can you clarify this?

Can you explain what "no luck" means?

I tried to flash a firmware through tftp after resetting it (holding wps button). I did not get a response from the the tftp server software... I closed the program and tried to reset the router again but only the power led went on. The router might have tried to flash the firmware despite there was no request or any log info, and resetting it again probably wiped the bootloader too. I have tried to use a tftp server again, even through the serial port with a programmer. Neither of the methods are working. Now it only acts as an ethernet switch. Btw it was on stock firmware, this was my first try flashing openwrt :weary:‏‏צילום מסך (15)
This is the ip my pc gets when it connects to the router with ethernet...

Lights coming on then going out means that some sort of bootloader is running.

If you end up with only the WPS light on a few seconds after you power up with the button held down, the bootloader is working in TFTP mode. Check your server. Connecting an Ethernet switch between the router and the PC helps keep the PC port from resetting while the router is off.

The PC needs to be set to the static IP 169.254.x.x IPs are set by Windows when in DHCP mode and there is no DHCP server.

Its not the wps led its the internet led... I set the ip to when trying to run tftp but as I said no response..

First things first...did you follow the official install documentation?

There is a very serious bootloader warning found there:

I mention this because you've failed to note it up 'til this point-in-time...and the warning states that you could accidentally wipe the bootloader if the steps are not followed to install OpenWrt with a TP-Link bootloader properly prepared and appended.

Oh yes I was trying to flash the image provided in the site with the bootloader in it...
I think the issue was the tftp server in windows 10. I should have used linux...

Did you switch off the Windows firewall during the operation ?

Yes, but I did not use a switch between the router and the pc.
The question is if there is something else I could do since there is no connection from the router to the server, not in Windows and not in Ubuntu.

Debricking archer C2
Looks like I can use a programmer to dump the firmware to the flash chip.. Unfortunately I don't have a backup... Can someone please find me a dump of the C2 V1m