Cannot flash WRTU54G-TM -- get "Incorrect image file!"

I'm trying to re-flash a WRTU54G-TM (please note the "U", it's there on purpose, this router is the T-Mobile HotSpot model with two phone ports along with WiFi.) I've tried the file:

lede-17.01.0-rc2-r3131-42f3c1f-adm8668-squashfs.bin

I've also tried several variants of the file:

openwrt-adm8668-squashfs.bin

All of them result in the error message "Incorrect image file!" and the router stays with its stock firmware.

I posted this question in the OpenWRT forum before it went belly up and got no answer. Anybody here have an idea of how to update the firmware on this router?

Regrettably not an answer, but https://openwrt.org/toh/hwdata/linksys/linksys_wrtu54g-tm indicates

Barrier Breaker 14.07 not built and Chaos Calmer 15.05 does not currently boot

I'm such a noob that those points don't mean a lot to me specifically, but I gather the gist of it is that this is a no-go for my router, with the chance of there being additional work done on it being about zero. Correct?

I can't speak for the devs, as there may be someone "motivated", but it's a 2007 device that only supports 802.11b/g and is limited by 100 Mbps Ethernet and a 200 MHz SoC.

It apparently had a build in 2012. Barrier Breaker 14.07 was in 2014 and Chaos Calmer 15.05 was in 2015.

Are you looking for the T-Mobile services, or just a router that you have lying around? If the latter, you'll likely be better served by one of the inexpensive (under US$20 or so), new devices in


(or if you can get a used TP-Link Archer C7, they're around US$40 here in "mint" condition)

I'm just trying to add it to my stable of routers. You're right, of course, it's not worth much, so sounds like I'll just sell it off as an "as-is" with stock firmware and move on. Thanks.