Cannot create bridged interface

Hello,

I am trying to create "Bridge Interfaces" on AP but the checkbox does not appear

Main Router - WRT3200ACM

Access Point - TP-Link EAP245

Main Router

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd01:7421:a229::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '5t 3 2'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t 4'
        option vid '2'

config interface 'GUEST'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '172.16.0.1'
        option ifname 'eth0.3'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '5t 3t 1'

Access Point

root@OpenWrt2:~# cat /etc/config/network

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option ula_prefix 'fd7b:ed88:4750::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.2'
        option gateway '192.168.1.1'
        option device 'br-lan'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 2t'
        option vid '3'

I need to create "Bridge Interface" on Access Point to separate GUEST traffic by VLAN tagging but cannot create Bridge Interface.

Please help me!

The network configuration format was changed in the OpenWrt development snapshots, and also in OpenWrt 21.02.0 release candidate 2 and later:

Your access point is using the new format, while your main router is still using the old one.

With the new format, a bridge device can be created in LuCI this way:
Network -> Interfaces -> "Devices" tab -> Add device configuration -> "General device options" tab -> Device type: "Bridge device"

In a second step, you can create a new interface, referring to the bridge device just created.

1 Like