Cannot connect to luci and pppoe after installation

Hey Guys,

I have installed the snapshot, and after that i am not able to connect to 192.168.1.1.
It says " 192.168.1.1 refused to connect."

I am able to connect to ssh with putty.
My ISP works on PPPoE, i cannot use internet without configuring the router.

I have tried using https://medium.com/@CTWiFi/lede-openwrt-configuring-pppoe-63ae3eaff766
method. but so far no success.

Do you have any suggestions?

ifconfig output
br-lan Link encap:Ethernet HWaddr 60:38:E0:91:80:BB
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fdf1:3479:ebe9::1/60 Scope:Global
inet6 addr: fe80::6238:e0ff:fe91:80bb/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:109535 errors:0 dropped:0 overruns:0 frame:0
TX packets:41191 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8101833 (7.7 MiB) TX bytes:6115392 (5.8 MiB)

eth0 Link encap:Ethernet HWaddr 60:38:E0:91:80:BB
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1298 errors:0 dropped:65 overruns:0 frame:0
TX packets:105620 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:277804 (271.2 KiB) TX bytes:9292032 (8.8 MiB)

eth1 Link encap:Ethernet HWaddr 60:38:E0:91:80:BA
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:109616 errors:0 dropped:253 overruns:0 frame:0
TX packets:41247 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9601618 (9.1 MiB) TX bytes:6221131 (5.9 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:310 errors:0 dropped:0 overruns:0 frame:0
TX packets:310 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:23496 (22.9 KiB) TX bytes:23496 (22.9 KiB)

root@OpenWrt:~#

vi /etc/config/network output

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdf1:3479:ebe9::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0 eth1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device 'lan_dev'
option name 'eth0'
option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan'
option ifname 'eth0'
option proto 'pppoe'
option username 'username'
option password 'password'

config device 'wan_dev'
option name 'eth1'
option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan6'
option ifname 'eth1'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 0'

~
~
~

  • /etc/config/network 1/46 2%

opkg update output
Downloading http://downloads.openwrt.org/snapshots/targets/ipq40xx/generic/packages/Packages.gz
Failed to establish connection
*** Failed to download the package list from http://downloads.openwrt.org/snapshots/targets/ipq40xx/generic/packages/Packages.gz

You have a mismatch in the wan interface eth0 vs eth1

https://openwrt.org/docs/guide-user/base-system/basic-networking

1 Like

Snapshots do not include LuCI by default. You need to install it with opkg.

opkg update
opkg install luci

My ISP is using pppoe so opkg update is not working

For some strange reason you are bridging eth0 and eth1 for lan. Strange.
What are you then using for wan?

I have been trying from last 3-4 hours. so might have added it from some link.

My current purpose is to get the LuCi up and running by any of the one option

  1. Make router use pppoe and connect to internet
  2. Make router to use my phone wifi hotspot

I told you to install 19.07 snapshot and gave a link. But you installed a master snapshot without Luci.

The only thing you needed to setup pppoe was to change wan proto to pppoe and add options for name and password. But you changed a lot wrong.

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdf1:3479:ebe9::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device 'lan_dev'
option name 'eth0'
option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan'
option ifname 'eth1'
option proto 'pppoe'
option username 'username'
option password 'password'

config device 'wan_dev'
option name 'eth1'
option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan6'
option ifname 'eth1'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 0'

This config should work. But you need to add real name and password.

Another way is to download a 19.07 snapshot and install using sysupgrade -n.

Thanks a lot Pilot,
Yes, i think i did messed up a lot of configuration.

After updating the settings, was able to take my router up and running.
Thanks once again.

Currently when i am trying to update some of the apps. I am getting below message.

  • The installed version of package kernel is not compatible, require 4.19.65-1-adce8099… while 4.19.64-1-adce8099… is installed.

So download a 19.07 snapshot and install it. It is more stable.

And also with snapshots you cant install kernel modules if kernel version doesn't match. You need to re-flashe the image first.

If you find you cannot install 19.07 using LuCI due to an error message, you can use the sysupgrade method described in this post I replied to you if you wish to 'downgrade' to OpenWrt 19.07 snapshot.
https://forum.openwrt.org/t/installing-openwrt-on-linksys-ea6350-v3/42161/7

Why won't we be able to install using Luci?

I haven't tested it on ea6350v3, but I know trying to revert to a release that uses an earlier kernel version on HH5A (eg. 4.14 to 4.9), always throws up a LuCI error message. I also tried to install 19.07 snapshot on an Archer C50v4 running latest development snapshot using LuCI and it failed and threw up usual error. (I've now amended my earlier post in case I am mistaken about e6530v3).

What is HH5A? I flash back and forth kernel versions with no problem. sysupgrade doesn't check it unless something recently changed there. Now I am using mostly 19.07 builds.

BT Home Hub 5A
https://openwrt.org/toh/bt/homehub_v5a

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.