Cannot connect to internet from OpenWrt

Hi there,

I am using two FritzBoxes in my network. The first is the one that is connected to "the internet" (ppoe). This should not do anything but forward the requests to the second box on which OpenWRT is installed.

On the OpenWRT router I have setup the LAN interface (eth0) with static IP and enabled DHCP. In addition, I setup the WAN interface (eth1) with static IP

  1. While the computer gets a matching IP address on connection to the OpenWRT router ( I cannot access any sites. I am wondering if the DNS setting is missing. To what IP should the DNS setting point to?
  2. I tried to create a IPv4 route on the FritzBox (ppoe) assigning the LAN range of my internal network to the WAN address of the OpenWRT router ( => with subnet mask but the FritzBox rejects saving with "Route not allowed".

Thanks for any hints!

static IP means you have to input DNS IPs yourself.

1/ which ever , Google's

2/ you either have to connect the 2nd router as dumb AP, or if connecting it as router, make sure the lan subnets differ between the two devices, and connect WAN->LAN.

Hi frollic,

thanks for your quick reply.

  1. I added as "Use custom DNS servers" address to the LAN interface but still, no connection to any site
  2. I already attached the WAN port of the OpenWRT to the LAN port of the FritzBox. Should the IPv4 route maintained in the FritzBox notpoint to the IP address with which the OpenWRT router is known to it? In the network tab of the FritzBox I do see the OpenWRT router with an IP adress of the DHCP server range. Should I use that IP for the route?

Did you reboot or refresh the DHCP lease on the clients after doing so ?

Yes, what's also strange that I am not able to ping Destination net not reachable.

Change the WAN port setting in your 2nd router to DHCP client, at least temp, see if it works.

I disabled the DHCP featur for the wan interface of the OpenWrt but still no connection. The client displays the following network settings:

DNS Server:
Search Domains: lan

I ran a traceroute to and as the only point I retrieved:
openwrt (

That's not what you were told to test ...

Ah, I did not know how to switch to that mode but now I found it. Protocol of WAN interface is now "DHCP Client". Still no connection but traceroute now displays:

1 openwrt (
2 openwrt (

Just to verify, what IPs are shown on the LAN and WAN interfaces, on the 2nd router ?

WAN: (this is also the IP shown up in the FritzBox's connected devices list, so connection between both routers does exist)

Thanks for your support!

Then it should work, if you connect a computer directly to the 1st router, does internet work ?

Yes, all other devices are connected to the FritzBox and they all work fine.

Then I suggest you reset the 2nd router, it should work out of the box, if it's connected LAN->WAN.

What do you mean by "reset"? Does a reboot help or do I need to perform a special command on LuCi?

There's a reset option in the firmware sub menu.

1 Like

OK, I performed the reset. Afterwards, the connection to the internet was possible.

But to get hints on the issues I had so far: There are now three interface entries that have been created automatically:
LAN (br-lan)
WAN (eth1) IPv4 only
WAN6 (eth1) IPv6 only
It seems as if I have selected the incorrect type of the LAN interface, right?

Don't know, hard to say.
What you see now, is the standard setup, whatever you did, was probably for nothing, and apparently incorrect ,)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.