Cannot configure mesh

I can not get mesh to work,
looks weird to me that "encryption none"

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'mesh'
	option mesh_id 'npns'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option encryption 'sae'
	option key 'key'


You can only use one mesh per lan. You have 2 mesh configured for the same lan. The "encryption: none" is a LuCI bug they will fix in the next release - it is encrypted as shown in the wireless configuration file.

Ok, the encryption is displayed in luci wrong...

But there is no wifi network with the specified ssid in my howse

Has it been corrected in master?

Most devices can't see a mesh network or connect to it. In order to connect to it you have to make a regular wifi network using the other radio and assign it to the lan.

I think it has been corrected in 22.03.2.

I think I got this mesh thing completely wrong.
my routers are not reaching each other via wifi with ( with a goog quality signal ) so the routers are connected between them via cable.

In order to have a single SSID wireless network in my house with multiple access points I configured my routers with the same SSID, same encryption method and same password.

Is there any other configuration needed ?

You have indeed.
A mesh network is an infrastructure "backhaul" that uses wireless technology to communicate between meshnodes.

This is WiFi roaming (aka 802.11r fast transition) and has nothing to do with mesh networking (802.11s).

Your confusion is due to at least one well known manufacturer advertising "mesh" products that are actually "roaming enabled" access points and not mesh at all. Presumably the marketing department has a disconnect with the technical department..... Anything that will sell product I guess.

This is compounded with a lack of documentation about 802.11r fast transition.

If you want to read about 802.11s mesh networking, take a look at:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.