Cannot build build due to broken gdb

Anyone finding that gdb does not build against latest commit? Link to make output.

@hnyman - I see you recently committed some gdb stuff.

It is probably due to the gdb update, just clean the whole toolchain and it should build


Have you cleared the whole toolchain with "make dirclean"? (or manually)

I did run make dirclean but got the same error:

 make[3] -C toolchain/gcc/final compile
    ERROR: toolchain/gdb failed to build.
make -r world: build failed. Please re-run make with -j1 V=s or V=sc for a higher verbosity level to see what's going on
make: *** [/scratch/union/include/ world] Error 1

Ran make distclean now and am trying again.

EDIT: that did the trick. Odd that the dirclean target did not.


Glad that you got it solved.
The toolchain is tricky sometimes after upgrades of build components.

And "make dirclean" is sometimes too detail-target-and-toolchain-version specific and does not always clean everything.
For that reason I sometimes manually clean build_dir/toolchain... and staging_dir/toolchain...

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.