Cannot Boot Pi 3 B+


I am attempting to set up a Pi 3 B+ with OpenWRT however I am struggling to get a successful flash. I believe the appropriate version for this device is however I have attempted both the EXT4 and Squash versions both 32 and 64 bit just to be sure and am having no success.

When I attempt the SSH it says Connection Refused.

I plugged the Pi into another Screen and it appears the Boot is stuck at the line

kmodloader: done loading kernel modules from /etc/module.d/*

I can see from other examples that this is near the end of the script.

Anyone have an Idea what I can try to solve this challenge?

though your download link points to the image selector for the 2B, the result would still be correct, as 2b and 3b share the same image.

Have you tried, to first install and run once the official RaspOS vendor firmware? In some cases, this does seem to do some obscure, but needed preinitialization of the hardware.

and I would additionally test the 23.05rc3 images.

How would I include the RaspOS Firmware? I was on Raspian before I Flashed the SD Card the First time. Each Time After I Erased the Drive before Flashing with the Pi Flasher.

I have also attempted with the rc3 image as well.

Every time the Terminal ends on the same line

kmodloader: done loading kernel modules from /etc/module.d/*

I am not sure if there is an issue with my Pi or if this is part of the process but I have no Keyboard or Mouse Control when the Pi Boots

That is correct, i meant Raspian. So you should already be fine regarding this prerequisite.

This is like the 6th or so console output line right after start. Ther should be a few dozend more lines, also keyboard driver and SSH loads later.

I have a 4 and a Zero. My Rpis with OpenWRT seem to boot into a first mini Raspian FAT partition that then boots into a second partition with OpenWRT. My guess is that there is something odd on this 2nd partition on your image (assuming the 3B image has the same design), since yours fails so early in the boot process.

Maybe something went south, when writing the image.

  • Did you remove all existing partitions of the SD and rewrite all (I think the OpenWRT image creates 2 of them by default)
  • Which which tool did you use to write the image to SD card?

Yea I saw some other examples and there are definitely a few more lines before the OpenWRT Logo shows up and you can connect.

I have attempted with both the Balance Etcher Application and the Native Pi Flasher

As far as I can tell there is only a single partition on the SD, and it is very small, much less than a single GB

I think here lies your problem, I think you are missing the second partition. My guess is the 3B should also have 2 partitions.

this is how my RPI 4 and Zero SD-Cards look like, after image is applied via (


Won’t let me link the photo, but this is what I see

I have a Boot Partition and a Rootfs participation. The rest is Free Space

no idea, what is going on.

But something must be odd with writing the partitions on SD card. Mybe try a different SD writer tool?

I have been using the Pi Flasher, I just attempted with the Balena Etcher tool and it still no luck...