Cannot access router page unless i press the reset button on a mikrotik hAP ac2

I was having trouble configuring openwrt on a mikrotik hap AC2 because i cannot access the router page when i try to reboot router manually or from the web page.

This started happening when i tried to flash openwrt. Since the router automatically reboots when you start to flash, I can no longer access the web page even after waiting for an hour. I can only start accessing the router page if I power off the router, hold the reset button, power on the router, wait for the "user" led to blink and release the reset button. Fortunately after doing this i can now access the router page and it flashed fine. This also still happens even after i flashed it permanently. I have to do the reset thing after reboot and thankfully it does not reset configuration. I tried all the builds starting from 21.02 up to date and i still have this problem

Any insights on how to troubleshoot this problem will be helpful. Thank you.

Did you install the kernel and then follow that up with the sysupgrade version? You need to upgrade via the sysupgrade process AFTER the initramfs (kernel) has been installed if you want to complete the installation process.

Sounds like your primary RouterBoot is v7. If that is the case, "upgrade" it back to a v6 RouterBoot.

1 Like

I found out whats wrong.
I was sure i downgraded to v6 RouterOS. Unfortunately I made a terrible mistake for I mistakenly used arm64 for the firmware instead of the standard 32-bit version.
Everything works fine now after using netinstall in linux
thank you for the support.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.