Cannot Access Luci and Wi-Fi not working!

I have a LAN cable connected to Raspberry Pi 3 B because I'm unable to connect my routers access point also I'm not able to browse Luci.

My network config is as follows:-

root@OpenWrt:/etc/config# cat network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5d:d8cd:3ba7::/48'

config interface 'lan'
	option type 'bridge'
	#option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option dns '192.168.0.1'              #My router's IP
	option gateway '192.168.0.1'

config interface 'wan'
	option type 'bridge'
	option proto 'dhcp'
	option ifname 'eth0'
	#option peerdns '0'
	#option dns '8.8.8.8'

My wireless config:

root@OpenWrt:/etc/config# cat wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
	option htmode 'HT20'
	option disabled '0'
	option country 'IN'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'xxxx'
	option encryption 'psk2'
	option key 'xxxx'

I have the following services enabled:

root@OpenWrt:/etc/config# netstat -n -l -p
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      6322/uhttpd
tcp        0      0 192.168.0.8:53          0.0.0.0:*               LISTEN      6211/dnsmasq
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      6211/dnsmasq
tcp        0      0 192.168.1.1:53          0.0.0.0:*               LISTEN      6211/dnsmasq
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      386/dropbear
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      6322/uhttpd
tcp        0      0 :::80                   :::*                    LISTEN      6322/uhttpd
tcp        0      0 fe80::ba27:ebff:fe43:298d:53 :::*                    LISTEN      6211/dnsmasq
tcp        0      0 fe80::ba27:ebff:fe16:7cd8:53 :::*                    LISTEN      6211/dnsmasq
tcp        0      0 ::1:53                  :::*                    LISTEN      6211/dnsmasq
tcp        0      0 fe80::ba27:ebff:fe16:7cd8:53 :::*                    LISTEN      6211/dnsmasq
tcp        0      0 fd5d:d8cd:3ba7::1:53    :::*                    LISTEN      6211/dnsmasq
tcp        0      0 :::22                   :::*                    LISTEN      386/dropbear
tcp        0      0 :::443                  :::*                    LISTEN      6322/uhttpd
udp        0      0 192.168.0.8:53          0.0.0.0:*                           6211/dnsmasq
udp        0      0 127.0.0.1:53            0.0.0.0:*                           6211/dnsmasq
udp        0      0 192.168.1.1:53          0.0.0.0:*                           6211/dnsmasq
udp        0      0 0.0.0.0:67              0.0.0.0:*                           6211/dnsmasq
udp        0      0 :::547                  :::*                                477/odhcpd
udp        0      0 fe80::ba27:ebff:fe43:298d:53 :::*                                6211/dnsmasq
udp        0      0 fe80::ba27:ebff:fe16:7cd8:53 :::*                                6211/dnsmasq
udp        0      0 ::1:53                  :::*                                6211/dnsmasq
udp        0      0 fe80::ba27:ebff:fe16:7cd8:53 :::*                                6211/dnsmasq
udp        0      0 fd5d:d8cd:3ba7::1:53    :::*                                6211/dnsmasq
raw        0      0 ::%2147479552:58        :::*                    58          477/odhcpd
raw        0      0 ::%2147479552:58        :::*                    58          477/odhcpd
Active UNIX domain sockets (only servers)
Proto RefCnt Flags       Type       State         I-Node PID/Program name    Path
unix  2      [ ACC ]     STREAM     LISTENING       2188 137/ubusd           /var/run/ubus.sock

What am I missing? Is there any service misconfiguration?

Are you using a snapshot build, or are using a stable release? The stable releases come with LuCI preinstalled, but the snapshot builds do not (so you have to install it manually over SSH).

https://openwrt.org/docs/guide-user/luci/luci.essentials

I'm using a stable built and I've installed Luci-ssl package can confirm that luci is installed.

You have eth0 as both wan and lan that will not work.

What is your intended use case? Things like a file server or VPN client or server are usually run as a LAN device. As a LAN device you give the Pi an IP on your LAN (in the same range, but not a conflicting address) and specify the main router as the gateway (and usually the DNS). This is all in the lan configuration. There would be no wan network.

My goal is to just connect to an AP and use is day to day life.

Okay!! but then why isn't the Wi-Fi working?

That has already been explained to you:

You currently have WiFi connected to LAN and WAN, this config is wrong and likely the source of many problems. One obvious and possible problem is that your WiFi may be incorrectly exposed to both the LAN and WAN DHCP servers.

Okay I got it working!!

Thanks for the response.

1 Like