Cannot access LUCI after fresh install

Router: TP-LINK WDR4310

I bought this router pre installed with an older version of openwrt, so decided to upgrade the firmware via the web interface to version 21.02.2 while preserving settings. Before the upgrade wifi on the router functioned properly.

After upgrading, the wifi interfaces were not available any longer. With a wired connection I was also not able to access the web interface. I am able to SSH into the router and the install seems to be correct, and I can access the internet through the cli. Luci packages are installed and the wifi interfaces are configured.

Troubleshooting steps tried:

  • checked that wifi was up
  • rebooted the router a few times
  • reinstalled openwrt with the -n option to revert to factory settings

None of this helped. Any ideas what I should try to fix this?

You mentioned "older", can you still verify what was that version? There are a lot of changes that happened and some old configuration is no longer usable on newer OpenWrt versions. The only thing you can do is save your old config, and try to replicate it on a freshly installed image.

Also make sure that your device is fully supported by v21.02.2, You can also try the latest snapshot and see if that fixes your issues.

It was version 17 or so. I thought that might be the issue hence tried to do a fresh install using sysupgrade and the -n option to make sure no config was copied across.

Is there anything else I need to look out for when trying to do a completely fresh install?

I tried checking the hardware table and it seems your device should be supported

Is this your exact device?

What you can do is retry power-cycling your router and redo a fresh install.

If this still doesn't work, you can try installing the SNAPSHOT version, as this one may contain several fixes for your problem.

Do note that SNAPSHOTS are experimental, make sure you have a way to restore your device if something goes wrong.

When you try to access luci, (be sure to use the numeric IP and not a hostname) does the browser tell you that it can't connect? If so, check

netstat -anpt

And see if uhttpd is running and listening.

The tl-wdr4310 should be (is) fine with current OpenWrt, but yes, the migration from ar71xx to ath79 might look a little confusing.

  • First of all, make sure that you really flashed 21.02.2 and not a snapshot build (which wouldn't come with the webinterface).
  • Next step would be letting the router fully boot up (give it ~3 minutes after powering up).
  • At this point, are you getting an IP address (192.168.1.x) via DHCP?
  • Clear your browser cache, http redirects can be very stubborn, also have a look at incognito mode or another (not your usual one) browser.
  • Try to access your router via ssh (if this succeeds, great, flash the correct sysupgrade image again from the ssh shell).
  • If you didn't have success so far, press the reset button for >10s to invoke a factory reset (again, give it ~3-4 minutes to fully boot up).
  • In case neither of these steps worked, push-button tftp may be available (if it actually is, depends on the installed OEM bootloader - originally it wasn't available, but it was retrofitted in later OEM firmware upgrades sometime around 2013/ 2014, depends on if that had been installed in its previous life).

If neither of these steps work, you may be up for serial console access or reflashing the spi-nor flash externally, but given the going rate for these devices on the used markets, doing that wouldn't be economically viable anymore (unless you already own all the necessary equipment or have a solid wish to re-use them in the future).

Even more confusing will be that the OP won't be able to access LuCI...because it's not included in snapshots.

I'm wondering what was installed initially.

Can you SSH in to the router?

If so, run -

ubus call system board

Post the results in preformatted text, by using the icon highlighted in red..

OpenWRT Posting Icons

Thanks for all the feedback so far, really appreciate it. This is one of the best forum experiences I've had!

I've made a little bit of progress - doing a hard reset of the device cleared the settings from the previous install, and I can now log in to luci at Next step is to enable wireless as per the instructions here:

However, luci has no menu item at Network>Wireless, and via ssh 'uci show wireless' returns 'uci: Entry not found'.

In answer to some of your questions:

root@givemetp:~# ubus call system board
        "kernel": "5.4.179",
        "hostname": "givemetp",
        "system": "Atheros AR9344 rev 2",
        "model": "TP-Link TL-WDR4310 v1",
        "board_name": "tplink,tl-wdr4310-v1",
        "release": {
                "distribution": "OpenWrt",
                "version": "21.02.2",
                "revision": "r16495-bf0c965af0",
                "target": "ath79/generic",
                "description": "OpenWrt 21.02.2 r16495-bf0c965af0"

Anything I'm missing? Screenshot of the network menu attached - no wireless option!

luci network menu

And for good measure, a photo of the model number on the back of the router:

If you can SSH in to the router, run -

cat /etc/config/wireless

Redact the passwords in the "option key" sections.

Post the results in preformatted text, by using the icon highlighted in red...

OpenWRT Posting Icons

Failing that, run -

opkg list-installed

and post in preformatted text.

Here you go - thanks!

root@givemetp:~# cat /etc/config/wireless
cat: can't open '/etc/config/wireless': No such file or directory
root@givemetp:~# opkg list-installed
base-files - 1439-r16495-bf0c965af0
busybox - 1.33.2-2
ca-bundle - 20210119-1
cgi-io - 2021-09-08-98cef9dd-20
dnsmasq - 2.85-8
dropbear - 2020.81-2
firewall - 2021-03-23-61db17ed-1
fstools - 2021-01-04-c53b1882-1
fwtool - 2019-11-12-8f7fe925-1
getrandom - 2020-10-25-9ef88681-2
hostapd-common - 2020-06-08-5a8b3662-39
ip6tables - 1.8.7-1
iptables - 1.8.7-1
iw - 5.9-8fab0c9e-3
iwinfo - 2021-04-30-c45f0b58-2.1
jshn - 2021-05-16-b14c4688-2
jsonfilter - 2018-02-04-c7e938d6-1
kernel - 5.4.179-1-3dfa0daff435bb57055a8e5b5a232fe2
kmod-ath - 5.4.179+5.10.85-1-1
kmod-ath9k - 5.4.179+5.10.85-1-1
kmod-ath9k-common - 5.4.179+5.10.85-1-1
kmod-cfg80211 - 5.4.179+5.10.85-1-1
kmod-gpio-button-hotplug - 5.4.179-3
kmod-ip6tables - 5.4.179-1
kmod-ipt-conntrack - 5.4.179-1
kmod-ipt-core - 5.4.179-1
kmod-ipt-nat - 5.4.179-1
kmod-ipt-offload - 5.4.179-1
kmod-lib-crc-ccitt - 5.4.179-1
kmod-mac80211 - 5.4.179+5.10.85-1-1
kmod-nf-conntrack - 5.4.179-1
kmod-nf-conntrack6 - 5.4.179-1
kmod-nf-flow - 5.4.179-1
kmod-nf-ipt - 5.4.179-1
kmod-nf-ipt6 - 5.4.179-1
kmod-nf-nat - 5.4.179-1
kmod-nf-reject - 5.4.179-1
kmod-nf-reject6 - 5.4.179-1
kmod-nls-base - 5.4.179-1
kmod-phy-ath79-usb - 5.4.179-1
kmod-ppp - 5.4.179-1
kmod-pppoe - 5.4.179-1
kmod-pppox - 5.4.179-1
kmod-slhc - 5.4.179-1
kmod-usb-core - 5.4.179-1
kmod-usb-ehci - 5.4.179-1
kmod-usb-ledtrig-usbport - 5.4.179-1
kmod-usb2 - 5.4.179-1
libblobmsg-json20210516 - 2021-05-16-b14c4688-2
libc - 1.1.24-3
libgcc1 - 8.4.0-3
libip4tc2 - 1.8.7-1
libip6tc2 - 1.8.7-1
libiwinfo-data - 2021-04-30-c45f0b58-2.1
libiwinfo-lua - 2021-04-30-c45f0b58-2.1
libiwinfo20210430 - 2021-04-30-c45f0b58-2.1
libjson-c5 - 0.15-2
libjson-script20210516 - 2021-05-16-b14c4688-2
liblua5.1.5 - 5.1.5-9
liblucihttp-lua - 2021-06-11-3dc89af4-1
liblucihttp0 - 2021-06-11-3dc89af4-1
libnl-tiny1 - 2020-08-05-c291088f-2
libpthread - 1.1.24-3
libubox20210516 - 2021-05-16-b14c4688-2
libubus-lua - 2021-06-30-4fc532c8-2
libubus20210630 - 2021-06-30-4fc532c8-2
libuci20130104 - 2021-04-14-4b3db117-5
libuclient20201210 - 2021-05-14-6a6011df-1
libustream-wolfssl20201210 - 2022-01-16-868fd881-1
libwolfssl5.1.1.99a5b54a - 5.1.1-stable-1
libxtables12 - 1.8.7-1
logd - 2020-10-25-9ef88681-2
lua - 5.1.5-9
luci - git-20.074.84698-ead5e81
luci-app-firewall - git-22.046.85957-59c3392
luci-app-opkg - git-21.312.69848-4745991
luci-base - git-22.046.85957-59c3392
luci-lib-base - git-20.232.39649-1f6dc29
luci-lib-ip - git-20.250.76529-62505bd
luci-lib-jsonc - git-19.317.29469-8da8f38
luci-lib-nixio - git-20.234.06894-c4a4e43
luci-mod-admin-full - git-19.253.48496-3f93650
luci-mod-network - git-22.046.85061-dd54dce
luci-mod-status - git-22.046.85784-0ac2542
luci-mod-system - git-22.019.40321-7a37d02
luci-proto-ipv6 - git-21.148.49484-14511e5
luci-proto-ppp - git-21.163.64918-6c6559a
luci-ssl - git-20.244.36115-e10f954
luci-theme-bootstrap - git-22.047.35373-cc582eb
mtd - 26
netifd - 2021-10-30-8f82742c-1
odhcp6c - 2021-01-09-53f07e90-16
odhcpd-ipv6only - 2021-07-18-bc9d317f-3
openwrt-keyring - 2021-02-20-49283916-2
opkg - 2021-06-13-1bf042dd-1
ppp - 2.4.8.git-2020-10-03-3
ppp-mod-pppoe - 2.4.8.git-2020-10-03-3
procd - 2021-03-08-2cfc26f8-1
px5g-wolfssl - 3
rpcd - 2021-03-11-ccb75178-1
rpcd-mod-file - 2021-03-11-ccb75178-1
rpcd-mod-iwinfo - 2021-03-11-ccb75178-1
rpcd-mod-luci - 20210614
rpcd-mod-rrdns - 20170710
swconfig - 12
uboot-envtools - 2021.01-10
ubox - 2020-10-25-9ef88681-2
ubus - 2021-06-30-4fc532c8-2
ubusd - 2021-06-30-4fc532c8-2
uci - 2021-04-14-4b3db117-5
uclient-fetch - 2021-05-14-6a6011df-1
uhttpd - 2021-03-21-15346de8-2
uhttpd-mod-ubus - 2021-03-21-15346de8-2
urandom-seed - 3
urngd - 2020-01-21-c7f7b6b6-1
usign - 2020-05-23-f1f65026-1
wireless-regdb - 2021.08.28-1
wpad-basic-wolfssl - 2020-06-08-5a8b3662-39

Congratulations, you are one step closer to making your device work. :slight_smile:

Looks like the firmware didn't detect WiFi, so it didn't create the config file (and why you don't have a Wireless menu selection).

Could be related to 21.02.2

Try downgrading to 21.02.1, and see if that works.

Don't keep any configs.

Thanks - I think I screwed things up more. I decided to try and downgrade to the latest 17.01.7 version. Now I can’t get an IP address from the router so no ssh or web access :joy:

Not sure how to proceed now. Lights are so it does seem to boot up as usual, but just can’t log in in any way

The oldest version that's supported is 19.07.n

I'd try using Failsafe mode first...

Failing that, you might try using the TFTP server method...

Finally figured this out. The router had the breed bootloader installed, rather than uboot. So I was actually able to access the breed recovery page and reflash with 22.02.2 image, this now lets me use one of the wifi interfaces on the router. I can see both Radios & both SSID in the wireless config section, but the second one doesn't work. Any idea on how to get both to work?