Cannot access local network PC on openwrt wifi repeater

Hi,
main router = Tomato-based Netgear
Wifi repeater = TP-LINK TL-WA860RE latest openwrt

Configuration: the TP-LINK is wirelessly connected to Netgear tomato router. I configured the Openwrt wireless as an Access Point.

Problem: PCs connected to Openwrt repeater cannot access any LAN PC's for file sharing or anything else. They can access the internet fine. They cant Ping anything on the LAN.

I have literally read, research, reconfigured, attempted WDS config, etc... for the last 5 hours continuous, and nothing works. Using non-Openwrt, I never had a problem configuring this setup to access my LAN. The same TP-LINK using its stock firmware could do this fine, but the firmware was buggy and required regular reboots. Openwrt has been rock-solid for 2 weeks that I have used it, but the lack of being able to access the local LAN for file sharing is a problem.

In past non-openwrt configurations, such as Netis WF2419 that I used for several years, and also a TP LINK 841 N router (used as a bridge), and now this 860RE with its stock firmware, ...as long as the repeater IP address was within the same range as the main router, the local network worked fine.

I have read that openwrt wants a different IP address range than that of the main router. I tried that and it changed nothing. Right now I am back to using an IP address within same range as my router.

I studied the Relay_configuration guide, but the article is apparently stale. For example, it says:
" Write a name for it ( repeater_bridge is the name I used in the example), and then choose Relay bridge in the Protocol of the new interface field"

Well, that does not exist. There is no "RELAY BRIDGE" option in the protocol choice of the drop-down menu.

A 2nd photo of my config:

Using wwan sounds complicated. Easiest for a wired connected repeater is the dumb ap model, without any routing or double NAT.

Basic "dumb AP" advice in wiki:
https://openwrt.org/docs/guide-user/network/wifi/dumbap

My old post about it:

Exactly, once you have that working, you can (optionally!) optimize it further (by enabling 802.11r, maybe even configuring 802.11k and 802.11v), but that doesn't get you much - and only for relatively recent/ highend clients can make use of these AP side hints to begin with.

Having a wired backhaul makes your situation rather comfortable and simple ("dumb AP" is really all you need), while also providing the best throughput possible. These days especially mobile clients tend to do rather sensible roaming decisions on their own - so other than using the same ESSID/ PSK for both bands and for all of your APs[0], there usually isn't a whole lot to gain (with 802.11k/v/r or potentially in the future, bandsteering, which isn't possible yet).

--
[0] channel selection is considered a bit more controversially, in terms of reducing handover times between BSSIDs it may help to use the same channels on all of your APs (although regular client-side background scanning ought to alleviate that) - but this does also leave out the option to avoid wireless congestion (dropping throughput) by using different channels. However if you are already living in a heavily congested urban area, your channels will be congested anyways, so sticking to the same ones won't be as hurtful as in less congested areas where you are the only wireless user.

Actually, did I read you wrong?
You only have a wireless connection to the main router? (Not wired)

Still the same idea, I think.
OpenWrt router could still be without routing and NAT, and let the main router to handle DHCP etc.

Wireless only. The purpose of the TP LINK unit is nothing more than to extend the range of wifi in my place.

i'll check out the dump AP article right now. Looks promising.

Currently I use wired connection to repeater myself, so I haven't experimented with wireless repeaters for some years.

But a few years ago I used WDS for getting my secondary router to be a repeater. Those were identical OpenWrt routers (WNDR3700 ath9k wifi), so WDS worked ok for me. I used the 5 GHz radio as the WDS backbone and only offered 2.4 GHz wifi for clients. WDS was possible with just a few config changes in the secondary router, as I approached it from this "dumped down" perspective. It was pretty much just about setting a fixed IP, disabling DHCP server and setting the 5 GHZ radio to STA mode and WDS (and naturally also setting WDS in the main router).

No luck with the dumb AP approach. Could not get the TP LINK to either access the internet nor access the LAN. Total failure.

Not sure where to go next. This has been an 8 hour project that previously was handled in minutes on several different stock firmware(!)

  1. Disconnect your dump AP.
  2. Reset your Dump AP's OpenWRT to its default settings.
  3. Connect your PC via a cable to the dumb AP to configure it.
  4. Go to the interface settings. Your LAN interface should consist of a bridge between the LAN and WiFi by default. This is exactly what we want. However, it has a DHCP server enabled by default. With a dump AP model, you will only want one DHCP server, but the router is already acting as one. So change the interface's protocol from static address to DHCP client
  5. Luci will probably lose connection, since there is now no longer a DHCP server, and revert settings after 30 seconds. If you apply the same settings again, it should give you an option to force these new settings. Do so.
  6. Disconnect your PC from the dump AP and connect the LAN port from the dump AP to the LAN port from your main router. Do NOT use the WAN port of the dump AP. Your LAN ports are bridged with the WiFi interface(s), and hence your LAN port should be connected to the router to connect both networks at the layer 2 level.
  7. Connect your PC to either a LAN port on the dump AP or the main router. Everything is connected at the Layer 2 level, so either should work and give access to the internet.
  8. Navigate to the main router's IP and login.
  9. In the list of DHCP clients, you should find your dump AP with a DHCP lease.
  10. Use this IP address to connect to the dump AP.
  11. Configure WiFi as needed.

If you have any questions let me know :slight_smile:

1 Like

My question with your instructions... is why the wired connection between the 2 routers? That would serve no purpose in my setup.

The goal here, and one which I have used for many years using other cheap routers and various firmwares, is to extend the wifi in my place. Router #2 (tp link) to have a WIRELESS WIFI connection to R#1, and client PCs will be connecting to R#2 by wifi too. No wired connections anywhere except from R#1 to the modem.

That part of the goal has been accomplished as far as Internet access. The problem has been the PCs connecting to R2 cannot access local file shares of devices connected to R#1 -- cannot ping any networked PCs connected to R#1. And this is only a problem with Openwrt. I have configured this setup easily before using stock firmware from both Netis and TP-Link, and various Tomato routers.

Yes, I have configured openwrt using a wired connection to my pc -- for setup only -- but there will not be any cable connected to anything after config.

Basically, a wireless repeater or wireless bridge between the 2 devices BUT that local file shares work, too. Not just internet access. I never had a problem configuring this setup before. I am new to using openwrt. but have extensive networking experience and probably 13+ years of using Tomato and-or DDWRT.

As I read your instructions, the cable would be part of the setup. Not what I need, nor possible here.

If I am misreading your instructions, I apologize.

When I say that, I mean that with all other firmwares I have used this config, as long as R2 has IP in same range as R1, the file shares work fine. ie R1 has IP 192.168.1.1. If you make R2 IP 192.168.1.50 for example, the file shares have always worked with other firmware with this "wireless repeater" setup.

NOT WITH Openwrt. Not only do the guides say to not use an IP address in the same range as R#1 (I have no idea WHY...), but whether you DO or DONT use IP in the same range, I have found no way to get the file shares working. I can get R2 to have internet connectivity using either IP in-same-range as R1 or different IP range than R1, but neither config has allowed files shares to work.

That is the only stumbling block. The fileshares dont work. I have even tried disabling the openwrt firewall, but that seems to only drop internet access for some reason.

And I tried the RELAYD setup, but reached a stumbling block because the one setup photo for INTERFACES - REPEATER_BRIDGE shows PROTOCOL -- "RELAY BRIDGE". Well, that doesn't exist, at least not in the 18.06.

You can try to replace the cable with a WDS link in this step:

However, please follow all other steps before attempting this.

Were you able to solve this @rpesq? I have the exact same problem. I tried everything that I could think of. My problem is that I have Router 1, that is the main router with a dhcp server and everything, it doesn't run openwrt. The second router does run openwrt and I can't pull a cable from the main router to it, so I would like to extend the wireless network.