Cannot access internet on my 2nd Router connected as Client wifi mode after blackout

I have a Linksys WRT1900ACS running OpenWrt 18.06.04 reset to default.

I suffered a blackout on my 2nd floor and since the reboot I do not have access to internet from my secondary router anymore. At first I thought some module could have been damaged or but after some testing everything seems to be working fine as explained below, except that I cannot connect to my gateway router anymore.

I have reset to default my Linksys and the gateway router (capped all-in-one ISP router that I cannot replace as I cannot extract the ONT credentials)

I had built a "Client mode" association via wifi to my main gateway router ( in order to:

  1. Extend wifi coverage on the 2nd floor
  2. Provide wired access to computers on the 2nd floor

In Network-->Interfaces-->LAN
I changed the "Static address" of my secondary router from to (different subnet)

In Network-->Wireless-->Scan (radio1)-->Join network
I joined in "Client mode" to the ESSID of my main gateway router providing the password and leaving the rest of the fields as default

Everything worked for years until yesterday blackout.

When I try to replicate the same steps now I end with a "wwan" interface not being able to obtain an IPv4 as before.

I was in 18.06.01 and upgraded to 18.06.04, reset to default and made a clean install.

I have tried to force the "wwan" interface protocol from "DHCP client" to "Static address" and force,,, but it does not work. Although I am sure that my gateway router has DHCP server activated as I receive a dynamic address when I connect my smartphone to it for example.

So I thought a module could have been damaged, therefore, I tried to create a hotspot on my smartphone and replicate the client mode association and... everything works perfectly. So it seems something between the Linksys and the gateway router, not being able to see each other or get a correct IP.

Smartphone hotspot client mode (got IPv4 and works)

Gateway router client mode (no IPv4 and does not work)

There are no custom routes or zones or firewall rules (router is reset to default each time I try a new config).

Does anyone know what could have happened? Or how I could get it to work as an hour before?


Does the main status page show that wifi is associated?

I prefer to manually configure a wifi client and attach it to the existing WAN network (remove the Ethernet port) rather than create a "wwan" or use the Join button. That and changing the LAN IP if necessary is all that needs to be done for a basic routed client.

1 Like

Thank you for the quick answer.

Yeah both the main page and in Network-->Wireless it appears as associated. I tried to lower the security from WPA2/PSK to WEP just in case.

When associated to the router I get no IP, when associated to the hotspot I get it.

I cannot figure what is wrong as I have started from scratch.

How is that method to create the wifi client and attach it to WAN? If I go to Edit the WAN interface I cannot see any field to select "Client mode" or add an ESSID to attach it to. Shoud I remove eth1?

Thanks again.

Under wan physical, pull down the box and type in wlan1 (and press enter, it won't add it if you just click out) if it isn't already in the list. Go back to wireless and confirm it changed there.

You enter all the wireless details on the wireless page. The network page connects the completed interface to a network.

1 Like

Thank you.

I ended flashing back old 18.06 and it works like a charm. It looks like 18.06.04 was messing with my 802.11n radio in the client mode when connected to routers.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.