Can not connect to device - only get "Self-Assigned IP"

Hello guys,

a couple of days ago I started using LEDE on my first device.
I could use the device for a couple of hours with wifi and ethernet.

Then I changed something (maybe related to dhcp) in the devices settings and now I can not connect to it anymore. Not through WiFi and not through Ethernet. On both channels I only get the "Self-Assigned IP" message in the network settings.

I also tried to reset it through the hardware button and connecting via the failsafe mode. Both apparently don't work.

Any suggestions?

More Info:
Device: TP-Link RE450 (Repeater)
Lede 17.01.4 generic re450

Devices I tried to connect:
iMac via Ethernet and Wifi
Macbook via Wifi
iPhone via Wifi
Android Phone via Wifi

None of them are able to connect to the repeater.

Can you provide me with some solutions?

BTW: I am not able to provide you with logs because I can't connect to it :smiley:

Looks like you disabled the DHCP server; let's assume there is nothing else broken.

Configure your computer to use a fixed IP address, instead of asking for one to the server; try with these parameters:

  • IP address =
  • netmask =
  • gateway =
  • DNS =

Now try first to ping the router at, then connect to it by WEB / SSH, and try to fix it.

Hey @eduperez!
Thanks for your quick response. I tried what you said.

I didn't found "gateway" on my settings so I typed it into "router" - is that the same thing?

Now when I ping the IP I get "Host Down" as a message back. Is that a good thing?!

Because the host is down I still can not reach SSH/Web on the device.

Do you have any other suggestions?

If you can't recover from this state, there is no TFTP recovery option on this model and you would have to use TTL to recover.

When you tried the failsafe mode, you were using an Ethernet cable plugged into LAN1?

yes I did use a wired connection to the device.

Yes, "router" is probably the same as "gateway"... it all depends on the preferences of whoever made the software.

And that is all the good news I have... if that did not work (and "host down" is definitively a bad thing), then you changed something else than the DHCP server, and things are going to be harder to fix.

Do you remember if perhaps you could have changed the IP address also? If we cannot guess the IP address for the router, or if the LAN interface is disabled, then your only options are failsafe mode or a TTL adapter.

So if I run the arp -a command I get these responses:


Can you try the solution with the packet sniffer documented in the failsafe:

Wait (with a packet sniffer) for a special broadcast packet and press a button (...)

This would at least tell us that your router can still be reached and possibly achieve failsafe. You can use Wireshark, available for Mac.