Can not access web GUI with LuCI installed

Hi, I could not access the web GUI via, with LuCI installed. When visiting, I get refused the connection. I tried both and

I can not find the WIFI of my router on my computer, so I connect my computer to the router through a cable. Using a cable, I can access my through ssh and I can also access to the Internet.

I am currently using Mi Router 4A (MIR4A)(Gigabit Edition), installing OpenWrt SNAPSHOT, r13499-7b4877c204 following this link. This snapshot do not have LuCI and I install LuCI using following commands according to Openwrt LuCI essential

opkg update
opkg install luci
opkg update
opkg list luci-app-\*

I also tried the command '/etc/init.d/uhttpd start' or '/etc/init.d/uhttpd enable'. I reboot my router several times. I also tried to change to or by editing /etc/config/network through ssh. However, these attempts did not work at all.

I also tried using the following command referring to this post

/usr/sbin/uhttpd -f -h /www -r -x /cgi-bin -t 60 -T 30 -k 20 -A 1 -n 3 -N 100 -R -p

and I get a strange page when visiting

Thanks for your attention! Thank you in advance!

ubus call system board

are you missing perhaps some of the output that came after when you ran this command?

in short... running third party firmware and expecting predictable outcomes for wiki guides is unrealistic... ( but credit to you for supplying relavent info in your OP... thankyou! )

your first point of call should be the maker of said firmware...

1 Like

in addition to what wulfy23 wrote.

Do you have anything in the /www dir, it looks very empty.

Thank you for your reply. It is my fault that I ignore the error report when installing luci, thanks for your reminding!

I got the following errors

root@OpenWrt:/etc/config# opkg install luci
Installing luci (git-20.074.84698-ead5e81) to root...
Installing libubox20210302 (2021-03-02-2e52c7e9-1) to root...
Installing libjson-c5 (0.15-1) to root...
Installing libblobmsg-json20210302 (2021-03-02-2e52c7e9-1) to root...
Installing libjson-script20210302 (2021-03-02-2e52c7e9-1) to root...
Installing uhttpd (2020-11-23-f53a6399-1) to root...
Installing libubus20210215 (2021-02-15-2537be01-1) to root...
Installing uhttpd-mod-ubus (2020-11-23-f53a6399-1) to root...
Installing liblua5.1.5 (5.1.5-8) to root...
Installing lua (5.1.5-8) to root...
Installing luci-lib-nixio (git-20.234.06894-c4a4e43) to root...
Installing libnl-tiny1 (2020-08-05-c291088f-1) to root...
Configuring libubox20210302.
Configuring libjson-script20210302.
Configuring libjson-c5.
Configuring libblobmsg-json20210302.
Configuring liblua5.1.5.
Configuring lua.
Configuring uhttpd.
Configuring luci-lib-nixio.
Configuring libubus20210215.
Configuring uhttpd-mod-ubus.
Collected errors:
 * check_data_file_clashes: Package libnl-tiny1 wants to install file /usr/lib/
        But that file is already provided by package  * libnl-tiny
 * opkg_install_cmd: Cannot install package luci.

And 'ubus call system board' get

        "kernel": "5.4.43",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "Xiaomi Mi Router 3G v2",
        "board_name": "xiaomi,mir3g-v2",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r13499-7b4877c204",
                "target": "ramips/mt7621",
                "description": "OpenWrt SNAPSHOT r13499-7b4877c204"

I will now trying to handling the error produced by installing luci.... Thank you again.

Yes, it is empty. In fact, I do not know anything about /www as a freshman to Openwrt.

you should really approach the firmware maker re: updates as there are known bugs and issues with snapshots older than a month or so... alternatively... read up re: 21.02 snapshot it may be supported on your board and a much stabler/reliable way forward for you...

( edit: I think in this case the firmware maker semi-intends the provided image to be used as a stepping stone during initial python based installer script... in this case an older firmware is not so much an issue... but once initially flashed... you should then update to an official image ... as intended via the stepping stone firmware )


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.