Can change DNS of ipv6?

Is it possible to change ipv6 dns? I wanted to put it from cloudflare and not from the ISP

I managed to configure ipv4 but I didn't find how to configure ipv6 because when trying to edit WAN_6 nothing appears

I changed ipv6 in Network > Interfaces > WAN > Advanced Settings > Use Custom DNS Server

(Using OpenWrt 21.02.3 r16554-1d4dea6d4f / LuCI openwrt-21.02 in RB750Gr3)

1 Like

This works for me :

3 Likes

I thought mine would be like this, but nothing appears :frowning:

on mine it just looks like this:

(Phone and PC)

then in /etc/config/network

config interface 'wan6'
	option ifname '@wan'
       .
       .
       .
	option peerdns '0'
	list dns '2606:4700:4700::1111'
	list dns '2606:4700:4700::1001'

and of course do a /etc/init.d/network restart after editing the file

1 Like

script to change your upstream router DNS to google dns. edit as required for your chosen DNS provider.

#!/bin/sh

# Network Configuration
# Disable peer/ISP DNS
uci set network.wan.peerdns="0"
uci set network.wan6.peerdns="0"
 
# Configure DNS provider to Google DNS
uci -q delete network.wan.dns
uci add_list network.wan.dns="8.8.8.8"
uci add_list network.wan.dns="8.8.4.4"
 
# Configure IPv6 DNS provider to Google DNS
uci -q delete network.wan6.dns
uci add_list network.wan6.dns="2001:4860:4860::8888"
uci add_list network.wan6.dns="2001:4860:4860::8844"
 
# Save and apply
uci commit dhcp
uci commit network
/etc/init.d/network restart
/etc/init.d/dnsmasq restart
/etc/init.d/odhcpd restart
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.