Builds for NETGEAR WNR1000V2, WNR1000V2-VC, WNR612v2, WPN824N, WNR2000v3, EX2700

Maybe if you apply them, then at least the PPP package will fit into the memory size?
By the way, I have no personal experience of building OpenWRT.

I'm working on builds for 21.02 right now, stay tuned. I'm very doubtful I'll be able to continue to include PPP support due to size limitations. This also likely means that L2TP support is also not possible.

I'm trying to retain IPV6 and LuCi support in the 21.02 builds.

By the way, this webpage lists all of the space-saving optimizations and configuration settings that I use to create these builds:

The settings are also viewable in the "config.buildinfo" file included in each firmware folder.

1 Like

It can be tricky. Are you flashing from the original NETGEAR firmware - or a current version of OpenWrt?

If you are flashing from the original Netgear firmware, try downgrading it to an older Netgear firmware version - perhaps the initial release - and then try flashing. I've had difficulty flashing when the device has a newer Netgear firmware version installed.

Additionally, double-check all of your TFTP and IP settings on the computer you are using to flash. Also, ensure you follow the proper boot sequence on the router so it is clearly in failsafe mode. (Step #4 above).

Thanks for getting back - that sounds like good advice. I am trying to flash from the newest version of the original firmware, yes. I can find v1.0.1.1 on the Netgear website. I'll give that a go. Or do you have the initial release you could share with me? Thanks.

For anyone experiencing the same thing as me, here's what worked: I tried flashing back to an old official firmware, but still experienced very slow flashing of Openwrt and erroring out every time after a couple of minutes. After reading a suggestion elsewhere about disabling the firewall, I switched computer (the one I was using didn't allow me to change firewall settings as it's a corporate pc), and disabled the firewall. Tried again, and everything worked as expected. Uploading of firmware was near instantaneous, and now I'm off to try and have this thing setup as an extender. Thanks for making the firmware available to us.

1 Like

I've built images of 21.02.1 for WNR1000v2, WNR2000v3, and WNR612v2 for testing. These images do not include PPP, SSL, OPKG or Relayd like the 19.07.X series. They include LuCi, IPv6.

I have not been able to test these images as I no longer access to these routers - use and flash at your own risk.

(21.02.1 Link Removed)

Backup your configuration via webserver, but flash new upgrades using SSH! Flashing via LuCi webserver most likely doesn't have enough memory to handle file upload.

Please report back with your comments in this thread and tell us if these images flash successfully and your device runs reliably.

(The WNR1000v2-vc and WPN82N are not available as their device profiles have not been submitted to the Openwrt codebase for the ath79 platform. Please submit these device profiles if you know how. Thanks to user Ashus and this thread for his helpful information in configuring size optimization options for 21.02. He has also successfully created his own 21.02 images for WNR1000v2, WNR2000v3, and WNR612v2 that you can try.)

1 Like

Can you give a tip how to flash the router via ssh?
Since my devices are currently in operation, as soon as I find a replacement for them, I will definitely check your builds on them.
Thanks.

Add:
Oh, it looks like I found the instructions in the topic you specified:)

1 Like

I dont know if this is the right place to ask but after messing arund with my WNR2000v3 a bit, it now always spits out this error message when trying to boot any (even the official) image:

Hit any key to stop autoboot:  0 
   Verifying Checksum ... OK
## Booting image at 9f050000 ...
   Image Name:   MIPS OpenWrt Linux-4.14.241
   Created:      2021-07-29  19:50:28 UTC
   Image Type:   MIPS Linux Unknown Image (uncompressed)
   Data Size:    1299456 Bytes =  1.2 MB
   Load Address: bf070000
   Entry Point:  bf070000
   Verifying Checksum ... OK
Wrong Image Type for bootm command

After that it goes back into TFTP recovery

I did this a while ago so i dont know anymore what exactly i did to mess it up this badly

Hi. Wnr612v2. After sysupgrade.bin flashing Luci doesn't work.

Can you replace wpad-mini package to at least wpad-basic for 802.11r fast roaming. Thank you

It won't fit, sorry. You can build your own custom firmware if you wish - but you'll have to strip out LuCi and/or IPv6 to make it fit.

Any chance of a 19.07.9 version now that's it's been released? Or are the changes less than trivial to fit into the available space? Thanks.

1 Like

I will build a 19.07.9 version, but it won't be ready for a few weeks.

2 Likes

If and when you get around to it, please build 19.07.10 instead :slight_smile: OpenWrt 19.07.10 service release

1 Like

Will do, should be ready by end of May.

1 Like

I've created 19.07.10 builds for all five devices, with a new additional build for the Netgear EX2700 Range Extender which previously could only run up to 18.06.9. All download links available in the first post above.

Please test and report any issues you may encounter, enjoy!

2 Likes

It seems to be running fine here - thanks a lot! According to the developers that's the final release in the 19 series, so I guess that's the final build from your hands. Much appreciated.

1 Like

You’re welcome. I’m testing builds of 21.02.3 as we speak, and those should be available by June 11.

1 Like

I've successfully built test images for 21.02.3, 22.03RC3, and the current master but I will not be posting them at this time. Unfortunately there seems to be a bug that causes the wifi to crash and restart when copying large numbers of simultaneous files between wireless clients on the LAN.

I don't think this issue is insurmountable, but it is going to require more debugging and testing. I'm unsure if the issue is related to image configuration, my test hardware (a WNR1000v2-vc), client hardware, a software bug, or a combination of all four variables. The issue is not present on 19.07.10.

I anticipate releasing test images of 21.02.3 sometime in the next two weeks, as I could use your assistance in testing them in different LAN/WAN environments.

I have a WNR1000v2 and I can help test. I don't know a lot about networking - I'm mostly using these older routers as "dumb" access points. But I'll give it a go - I just need to know what needs testing.

1 Like

I've created images for 21.02.3 for WNR1000v2, WNR1000V2-VC, WNR612V2, and WNR2000v3. They include LuCi, IPv6, Relayd. They do not include opkg, PPP due to space limitations and I've tested these images on the 2000v3 and 1000v2-VC.

Download 21.02.3 Builds for WNR1000v2, WNR1000V2-VC, WNR612V2, and WNR2000v3

Flashing Recommendations
I highly recommend flashing from an existing installation of 19.07.10 via sysupgrade, do not keep settings, and see Post #1 for additional information if flashing for the first time. I also recommend flashing via command line instead of LuCi, as you will likely not have enough free available memory to flash via LuCi menu (unless you unplug WAN port, temporarily turn off Wifi radio, reboot router to free up memory before flashing.)

Note: I've manually migrated the WNR1000v2-VC to the Ath79 target to build for 21.02. When you flash this model from 19.07.10 in Luci, you will see an error message. Select the "Force Upgrade" box, make sure "Keep Settings" is unselected, and click continue - it will flash normally.

Stability Warning
These images are mostly stable, but I've encountered a recurring wifi crash and device restart if you are copying a large number of files or create very heavy network transfer traffic between wireless clients if using device as a full router. If using the device as a properly configured dump access point these crashes do not occur.

Additionally, these crashes do not seem to occur when using the device as a full router if copying files over the network from wired to wireless clients, wired to wired clients, or typical internet browsing and streaming use among a variety of wireless and wired clients. I experienced stability for multiple weeks on a home network with 10 wifi devices, 2 wired devices, on a 300Mbps WAN connection - however, if I started copying many files between wireless clients the router would restart within a few minutes.

You can use iperf to conveniently test wifi client to wifi client network transfers and stability on your own network. Initiate an iperf connection between two wireless clients for at least 10 minutes and see what happens.

Recommendations
At this time my recommendation is to only operate these devices as a dumb access point if running 21.02.3.

It may also be reliable as a full router in a network environment with mostly wired clients and/or little to no wireless client to wireless client transfer traffic. If running as dumb access point, follow the instructions and disable unnecessary services (Ex. firewall, dnsmasq, odhpc, etc.) to conserve available memory. Free memory provides more stability, higher speeds, more wireless client capacity - the more free memory, the better...and every kB counts. Scheduling a periodic reboot via cron could increase stability over long periods although it is not necessary.

I'll continue to troubleshoot the cause of this wifi crash issue and appreciate users reporting their experience, network configurations, and specific situations when this may occur. (The same issue currently occurs on 22.03, master branch as well). The reality of the situation is that we're on the bleeding edge of incompatibility with the 5.4 kernel given the limited memory on these old Netgear devices.

Conclusion
The good news is that these Netgear devices can still be used successfully as reliable dump access points for the foreseeable future. I'll continue to debug the issue to hopefully enable use of these devices as a full router with the same solid stability we had on 19.07.

2 Likes