Build succeeds, but the specifically targeted binary is missing

I'm trying to build openwrt on MacOS, following the directions at
My target is TP Link WR-703N (I'm building a shairport-sync server).

Selecting the correct target in with make menuconfig, and building produces a long list of binaries for all the other AR7xxx/AR9xx devices (including all the other TPLink devices), but the 703N device I targeted is conspicuously absent.

Can someone shed light on this? Seems bizarre to me... I've tried many clean and build cycles but get the same result.

The TL-WR703N is a 4 MB flash device, which means it will be somewhere between very hard and impossible to make it fit into the available space. If you check a bit further up in your buildlog you'll probably find the corresponding error message to create the tl-wr703n firmware image. Oversized images are not a blocking error and are just reported with no image being created, as terminating the build for (usually-) multiple devices (easily over a hundred for a popular subtarget as ar71xx) just because of failing size checks for a couple of them would become a real problem (danger is averted by not leaving oversized images around).

An image is still been built for 17.01.5 so maybe try checking out the 17.01 branch and trying again.
Also if you set the target profile to your specific device in menuconfig you can avoid building all the images unless that is your intention

Once adding shairport and its dependencies to the 17.01.x branch, it will just as well fail to build, 4 MB just isn't enough for that. shaiport itself isn't too big at ~70 KB (but still a lot on a 4 MB flash device), but its dependencies (among them mbedtls) break the camel's back, without even looking any further.

1 Like

Thanks for the replies. My first order now is to setup build logging.
The reason I had an expectation this would be fine is the number of tutorials around for this exact use case (Shairport-sync) on this target. Indeed I have found an Attitude Adjustment binary for predecessor Shairport that flashes and works fine (other than glitchy audio- hence me building a -sync version). Granted, the diffference here may be the advancing version of OpenWRT being larger and leaving less room for Sp-sync. Perhaps I need to explore minimal versions without LuCi and/or I just need to pull an older version such as 15.x

In regards to building to my specific target : I had made the exact target profile selection for that reason in menuconfig. I was surprised then to see it build seemingly every ARxxx device except the one I wanted. So I don’t understand what has happened there.

Thanks again