Build OpenWrt with JamVM

Hi, can somebody help me with OpenWrt build? I would like to compile OpenWrt with JamVM...

I have APU2C4 HW ...

am@t410:~/openwrt$ javac -version
javac 11.0.3

am@t410:~/openwrt$ java -version
openjdk version "11.0.3" 2019-04-16
OpenJDK Runtime Environment (build 11.0.3+7-Ubuntu-1ubuntu218.04.1)
OpenJDK 64-Bit Server VM (build 11.0.3+7-Ubuntu-1ubuntu218.04.1, mixed mode, sharing)

am@t410:~/openwrt$ make -j1 V=s
checking for java... java
checking for ecj... no
checking for ecj-3.3... no
checking for ecj-3.2... no
checking for javac... javac -Xlint:unchecked,cast,divzero,empty,finally,overrides
checking if javac -Xlint:unchecked,cast,divzero,empty,finally,overrides is a version of gcj... no
checking if javac -Xlint:unchecked,cast,divzero,empty,finally,overrides works... configure: error: The Java compiler javac -Xlint:unchecked,cast,divzero,empty,finally,overrides failed (see config.log, check the CLASSPATH?)
Makefile:90: recipe for target '/home/am/openwrt/build_dir/target-x86_64_musl/classpath-0.99/.configured_68b329da9893e34099c7d8ad5cb9c940' failed
make[3]: *** [/home/am/openwrt/build_dir/target-x86_64_musl/classpath-0.99/.configured_68b329da9893e34099c7d8ad5cb9c940] Error 1
make[3]: Leaving directory '/home/am/openwrt/feeds/packages/libs/classpath'
time: package/feeds/packages/classpath/compile#18.60#3.49#21.60
package/Makefile:107: recipe for target 'package/feeds/packages/classpath/compile' failed
make[2]: *** [package/feeds/packages/classpath/compile] Error 2
make[2]: Leaving directory '/home/am/openwrt'
package/Makefile:103: recipe for target '/home/am/openwrt/staging_dir/target-x86_64_musl/stamp/.package_compile' failed
make[1]: *** [/home/am/openwrt/staging_dir/target-x86_64_musl/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/am/openwrt'
/home/am/openwrt/include/ recipe for target 'world' failed
make: *** [world] Error 2


Java stuff in OpenWrt is pretty much unmaintained.

Possibly the seven-year old code in classpath package does not recognise the current jdk. Your classpath configure does not recognise the output from javac...

Classpath is really old...

I do have the same problem as @xtreo does. Is there any solution for this? I searched the web and tried some hints. Even installed OracleJDK 12 instead of OpenJDK 11, but nothing has helped. Cannot finish bulding the source because of that. Is it really necessary to build JamVM which needs classpath? Cannot it just be safely omitted from building?

I got the same error.
To resolve this, I installed openjdk 7. Now I have another,
Makefile:532: recipe for target 'gnu_java_math_GMP.lo' failed

Have you found a solution for this issue? i have the exact same error
Makefile:532: recipe for target 'gnu_java_math_GMP.lo' failed

most likely to build this you need the now discontinued oss version of the jdk on the build system (aka. gnu classpath). if you're lucky some long eol'ed version of the jdk around 1.5 or 1.6 might do the trick. or just build jamvm with openjdk.

however, given you're hardware, it's far better to use the hotspot zero vm from openjdk insteadof jamvm (which hasn't seen a release in half a decade)...