Build OpenWrt for D-Link DIR-842

I am trying to do a custom build of OpenWRT for D-Link DIR-842 C1. So far so good. After battling compilation errors, I managed to compile the firmwares. All the firmwares are output to bin/ar71xx . I expected for another folder named bin/ar91xx since I chose Atheros AR7xx/AR9xx as target system in menu makeconfig . Anyway, in bin/ar71xx I cannot see the firmware for my specific router. The closest thing to that is:


I can't see any bin/ar71xx/openwrt-ar71xx-generic-dir-842-c1-squashfs-factory.bin What should I flash? The one for 825-c1 ?

EDIT: I flashed all those firmwares listed above they didn't work. I now know that the target system for this router is ath79 . But this target is not available in menu makeconfig

Use image from

Thanks for the quick reply! I want to compile from source, so I can use mptcp. The end goal for me is so that I can be able to combine both LAN and WIFI internet at the router level (I tested mptcp on laptop and it worked flawlessly). I have already compiled OpenWrt for ar71xx, I wish I could do the same for ath79 but I can't see the option in menuconfig

You need to git pull your build system to update it then select either trunk or 19.07. Do a complete distclean build since the toolchain needs to be updated as well.

ar71xx should be considered obsolete. ath79 does not exist in 18.06.

That seems exactly what I should do. Problem is, I need to merge two branches. First one is master (It has the mptcp support). Second one is 19.07 (It has ath79 support). Problem is, none of the branches has both of these features. I've tried to make it work but I hardly know how to use git, so I had to install GitHub Desktop. I then select master and then try to merge 19.07 into master (Should I be doing the opposite? No idea). I then get a window showing me that there will be 62 conflicted files. I click "merge". It then shows me another window which shows me that there are 236 conflicted files. Some of these are code files which open in Atom, but then I get two options for every conflict ("Use our changes" and "Use their changes"). I don't know what I should be selecting, since I don't know the history of those code changes. There are also *.patch files, these don't have an option to open in Atom. The app just shows "Use command line to resolve this file" and I have no idea what that means

Edit: What master are you talking about that has the support you need???

You need to manually find and merge the changes. git merge doesn’t magically understand intent.

Learning git basics will be essential.