Build for WRT3200ACM (Discontinued)

Yeah, a few package tweaks to hit all the policy based routing app's prerequisites.

Had DNS issue with the beta r3792. Have seen similar DNS problem in LEDE/Openwrt and also DD-WRT from time to time. Using the same DNS servers, Google in my case, I get pauses on DNS lookups watching Chrome browser. Sets for period of time saying resolving. Also some MXDOMAINs, which really appear to be timeouts, and just retry the site and everything comes up. As I said I have seen this before with various builds. Right now I am running davidc502 r3681 with the 4.9 kernel. Was running that before I installed your beta. Back on r3681 and am not seeing the same behavior.

This is just an update on my experience, not a complaint. :wink:

FYI, the 'beta' or master branch also contains a lot of experimental code. For instance, test or beta versions of dnsmasq and other primary components in OpenWRT/LEDE. That's why i'd like to always stick to something relatively safer.

But thank you for sharing your experience!

@cybrnook: I'd like to thank you for adding HW-acceleration support back into your builds at the expense of being incompatible with kmods from the snapshot repos. FWIW, I am happy to get off my lazy but and build an image for my router if you feel like the compromise of HW acceleration is not worth it for other users of your build (if people start complaining)

Thanks again for all the help!

Ya I know I am playing with not quite ready for prime time code when running the beta branch. Most of the time it works fine but once in awhile there is a glitch. I like playing with the different firmware available for the wrt1900acs v1, DD-WRT (Brainslayer's latest runs quite well), LEDE, and Gargoyle. Guess you could say I am a moving target with testing. :wink:

Did some checking and it looks like Google DNS is having issues yesterday and today. I was still seeing some of the something I was seeing with the r3792 with davidc502's build. Have changed DNS servers and now things appear to be working fine. Suspect that the beta r3792 would work ok for me as well.

Just posting this after HW acceleration enabled, running on a 200mbps/20mbps connection.
Previously this would max out at 35mbps download.

1 Like

Would you please told me which builds have HW acceleration? Thank you! I have a wrt1900acs.

The latest BETA/Stable both have HW-acceleration encryption/decryption enabled.
You need to use a compatible cipher with your VPN, e.g: AES-128-cbc/AES-256-cbc. Finally, you need to explicitly choose cryptodev as engine in your VPN settings.

Thank you for your detailed instructions. I'll try!

Not bad, not bad at all.....

What model router do you use?[quote="nidstigator, post:635, topic:545, full:true"]
Just posting this after HW acceleration enabled, running on a 200mbps/20mbps connection.
Previously this would max out at 35mbps download.

It's a WRT1900ACSV2

Hi! Newbie questions here:
WRT1200AC, some thoughts after moving from Linksys stock firmware to latest Lede beta by Cybrnook:

  1. Lower 802.11ac connection speed - 650mbit -> 150-300mbit on a 80Mhz channel width. Any thoughts? No other 5Ghz interferences in range.
  2. Bufferbloat. Stock firmware somehow avoids it, giving rock-solid latency while Speedtest is running with max available 50/50mbit channel speed.
    Tried SQM with recommended settings (cake, codel) + limiting tx/rx speed, but ping rises up to 1000msec on busy channel even though full bandwidth isn't used.
  3. Problem with external USB3 HDD: isn't visible among detected mount points. What I missed?

Thanks for your help!

The Wifi speed is just where it's at right now, the stock firmware has the closed source driver. Try changing the interface to eth1.2 for sqm cake layer cake. Not sure about the mounting as I don't use it.


I also have a WRT1200AC (v1)

  1. I haven't used stock linux firmware in forever, but I believe the latest linksys stock firmware update for the wrt1200ac is over a year old. Meaning the wifi drivers in LEDE are newer. I don't know why you are seeing such a drastic speed decrease. I certainly am not.

  2. I didn't start testing for bufferbloat until after I started using openwrt and LEDE, but the default SQM settings work extremely, extremely well for me. Choose cake and piece.of.cake, and make sure you are applying it to your WAN interface (eth0), and set the upload and download speeds to approx 95% of maximum.

  3. I believe this was discussed earlier in this thread and there is an easy fix. It eludes me at the moment as I don't use it.

Edit: Try using @cybrnook's latest Stable build, not beta.

Ok, fixed my issues:

  1. Lower speed was due to Auto selected lower 5GHz channels (36 mostly) and these channels have a TX power cap of 23dB, switched to 149 channel with 30dBi and got same speed as stock firmware.
  2. Bufferbloat is non-existent on STABLE Cybrnook build even without enabling SQM, same as stock firmware again. Sadly BETA branch has it.
  3. Problem with external HDD was not trivial to fix:
    I had to install 'opkg install libblkid' for auto-detection of /dev/sda1, then install proper ntfs driver instead of faulty default 'opkg --force-depends install ntfs-3g'
    then 'mount -t ntfs-3g /dev/sda1 /mnt/sda1' and finally share it via GUI.
    It worked, but hope @cybrnook will automate this process.
    Share speed is almost as good as stock firmware and much better than dd-wrt.

Good job! I'll stay on Lede

are there any wifi performance issues present with the wrt1900acs? Looks like you guys are pretty happy with those builds!

So while i am new to lede, is it possible to uninstall openvpn in this builds? Cause i want to go for a ipsec ikev2 vpn solution i dont Need openvpn

I don't understand what you mean about no buffer bloat, dslreport speed test shows buffer bloat on stable and beta builds until I enable sqm then it's eliminated on both. I also am quite stable on the latest beta 3792. I recommend manually disabling offloading with ethtool in the init.d sqm file.

No wifi performance issues with any of the WRT series except the WRT3200ACM due to drivers still maturing for the WiFi chipset it uses which is different from the rest.


  1. Glad you fixed your bandwidth issues. It was most likely due to channel being on auto -- although I myself prefer the high channels (149 and up so that I can also select 30dB transmit). However, the signal strength being transmitted shouldn't have anything effect on bandwidth (ideally neither should the channel -- but auto always seems to cause issues, and alot of devices seem to perform better on 149 and up as well).

  2. As for bufferbloat, I agree with @JDC2389, with SQM disabled, you should experience buffer bloat. And badly. On the stable and beta builds. I did until I enabled SQM.

As @JDC2389 also mentioned, look at my post from a week or two ago regarding disabling offloading by adding a line to the sqm init.d file for ever better SQM performance.

Actually the latest Brainslayer build r71791 03/30/2017 is faster on my 5GHz iperf test then LEDE builds I have run, cybrnook and davidc502 as well as Gargoyle. Coming close to stock in speed for me. Know that wireless is variable by location so this is just my experience. Never had DD-WRT out perform LEDE or Gargoyle before this build.

Regarding bufferbloat - firstly, my test was to run ping to a DNS server + doing regular
I accept, it may be a wrong test, but it is where I first saw a difference between stock fw and Lede BETA (ping spikes up to 1 sec). Setting up SQM didnt help.

Now on stable, the test above immediately produced great result with stable ping (SQM disabled).

Now I discovered DSLreports test and ran it on LEDE stable - it gives me no Bufferbloat result (A+) even without SQM. With SQM enabled I have the same A+.

I guess I need to recheck on LEDE beta again.