Build for Netgear R7800


#1183

You need to build and flash the whole firmware with that kmod. The kmod dependency checksumming prevents installing kmods into builds that have kernel options that are not 100% same.

You could also try overriding the dependency check with opkg options, but that may cause the kernel to crash.

That is one of the reason, why I provide the easy to use scripts to replicate my builds, as people do have different needs, and may need slightly different kernel modules.

/And it makes no sense to build all kmods into the build. E.g. your wish kmod-ipt-filter might be useful if you would do string-based packet content sniffing in firewall, but I have no use for that myself.)


#1184

I guess not. Any idea how much cpu it might use?
I was thinking about blocking certain sites base on hostname, maybe there's a better way to do that.

EDIT:
Running my build now, seems to work. Haven't tried the module yet tho'.
Built on gentoo with GCC 7.3.0,


#1185

18.06 builds fine for me. Strange...

Edit: Never mind, building 18.06 now. Will see if it is an issue with master or my build environment.

edit 2: 18.06 doesn't build either. I may try re-installing my build environment.


#1186

@hnyman

Is there any point in building with the Ath10k-ct firmware? Better perfomance, bug fixes?


#1187

I have never built with CT firmware, so no opinion.


#1188

Well, erasing my Ubuntu install and installing a fresh Kubuntu seems to have fixed my issue. No idea why.


#1189

Supposed to be bug fixes and some new features.
I tried building with it, router seems to work but I have no feedback on performance.


#1190

In addition to these two commands for tweaking the ondemand governor's sensitive, one can also limit the range of CPU scaling. To see what's available to the CPU:

# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies 
384000 600000 800000 1000000 1400000 1725000 

These values are in Hz and translate to 384 MHz to 1.725 GHz.

Echoing one of these values to the following file will limit the slows clock speed of the ondemand governor: /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq

I use cron to changes the min frequency from 384 MHz to 800 MHz during the day for my family. You can access it in Luci under System>Scheduled Tasks:

# crontab -l
### weekdays 5-11
0 5 * * 1-5 echo 800000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
0 23 * * 1-5 echo 384000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
### weekends 8-11
0 8 * * 0,6  echo 800000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
0 23 * * 0,6  echo 384000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq

How do I permanently change the scaling governor from ondemand to performance?
#1191

@hnyman
I played around some more and got a hang of how to use your buildscripts properly, thank you. Maybe i missed it but you can clarify in your description above that you can run updateNmake.sh to rebuild the image with latest "git-changes" (commits) if there's any. There's no need to run newBuildroot.sh for that.

This is only needed if you start from scratch again, but what are the benefits of using the same build key?

Also, since uhttpd is the default webserver, why haven't you included the luci-app for that in your own build?


#1192

No special benefits for casual builds.

It is a rather recent addition, so I have never bothered to add it into my existing script, (as the default settings are good enough for me). I am too used to editing the uhttpd config by hand, if needed :wink:


#1193

Hi, im new here in openwrt. Using hnyman build script for custom firmware openwrt, I found something (dont know if it's a bug).
I cannot ping any address (8.8.8.8 and www.google.com and yahoo.com) if there are heavy traffic download in my network. My sqm are enabled using cake > piece of cake. my internet connectivity bandwidth is 20Mbps/5Mbps, down/up. Browsing are fine, youtube is fine (when youtube was played, heavy download traffic are suppressed). However, ping command receive "request time out"). Is this normal?

UPDATE: This also affect other service such as openvpn. It stucks at wait status, if there are heavy traffic download


#1194

Any reply would be appreciated


#1195

Check out some insights in the SQM thread. Have you configured correctly the shaper

Follow the instructions:

https://openwrt.org/docs/guide-user/network/traffic-shaping/sqm

you have to take into account (if you have a xDSL) that 80-85% and configure your link layer adaptation


#1196

I’m using fiber. I already tried to set everything as the guide says but ping still give “request time out” when download traffic is heavy.

EDIT: a little note what I mean by heavy download traffic: torrent, IDM download in which it uses multiple connection to speed up downloads. Regular browsing and streaming doesn’t give “request time out”


#1197

Try changing client, might sound stupid but I've had major issues with uTorrent myself.


#1198

Long time lurker.
I am currently running, LEDE Reboot 17.01.2 r3435-65eec8bd5f / LuCI lede-17.01 branch (git-17.152.82987-7f6fc16). I've had this running for almost a year now. I can push about 800-900mbps on ethernet wired (i have gigabit connection). stock firmware from netgear was able to push mid 950mbps. So i consider openwrt/lede upto par.
lede is able to push around 400-560mbps on AC on my laptop.
I put my spare r7800 on most recent stable build and I was shocked at the difference. Ethernet was barely able to push 500mbps. wifi struggles to push even 200-300 on AC.
configuration was exact same for wired/wifi.
only thing good was that ssh public key auth was working on latest stable release. I don't mind entering password for software that works better.
Not sure what has reduced throughput, any thing that I can do to enhance it further. I would like to keep my connectivity as up to date as possible with the latest fixes for wifi and ssh/etc. I really want to be able to push this router to the max.

thanks.


#1199

Same issue here. I swtiched from Davids LEDE build (WRT 1900) to the R7800 with hymnans build but i only get 300 of 400mbps using ethernet. I tried the build from the 16th and 20th of september, no difference. I am not able to max out my internet speed anymore.

With Davids build i could always get the maximum of 400+. Not sure what i am doing wrong here. Wifi is realy good. No latency issues. No addons / settings changed, using standard.

Any ideas what i can tweak with the settings?

//Edit:

This has solved my issues:


#1200

Setting up_threshold to 35? I thinks that's too low, It will almost set to the max cpu freq all the time. While this may give good performance, what about the heat that it generates? With the default value, it already generate heat to about 60-62 degrees.


#1201

its on 54 degrees celcius right now. Not sure if it will get any higher.


#1202

What are the default values again (need to factory reset, i forgot :D) ? I will try find a sweet spot between minimum and max.