Build for Netgear R7800


#1163

Can't say i edited the original rules.. just added 2-3 new ones, I have to do some more testing.


#1164

Tried some more, it doesn't seem like the rules helped, it seems to work randomly, the output still hangs from time to time.
This got to be the most weird issue I've had for a while.


#1165

Well something along the path is breaking PMTU discovery. It must not be your router... could be the a company firewall or something.


#1166

Could be, once I login and run ps aux once and wait until it's done, then it works, however it's a bit slow but works.
I am going to try from another network.


#1167

You could try something like that and see if it helps (its a kind of shutgun approach but would at least confirm the theory):

iptables -I FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --set-mss 1200


#1168

Odd found.
Changing the forward to a freebsd host instead of the linux works fine, no delays.
Also changing to openssh instead of dropbear on the linux host seems to work a tad better, not perfect but better.

EDIT:
The real issue behind this is the corporate firewall, it might be doing deep packet inspection or something. because when I tried another connection it was blazing fast.
What really made me notice the problem was because I changed to dropbear, like I said above, now when I'm back to openssh things work, output is slow sometimes but never hangs like it did with dropbear.


#1169

It works but after restarting the router I have to re-enter the commands. How do you set these commands permanently?


#1170

You add them to some script that is run at each boot.

easiest is /etc/rc.local file


#1171

I've been having wifi go down often at my house. I'm on OpenWrt SNAPSHOT r7924-2211ee0037 but for quite a while wifi has been terrible, it disappears for a few and then it comes back, I haven't flashed back to regular firmware to see if its hardware issue. I have flashed to clean master and redone settings manually but it hasn't helped.


#1172

Check the cpu load and temps so you don't have a process eating all cpu, that might kill wifi. A few builds back there was a problem with /usr/sbin/nlbwmon eating cpu but that seems to be solved now.
I have no issue with wifi since then.


#1173

cpu loads are fine, I disabled nlbwmon back then cause I would get hit with that bug. I'll try and do a full clean on router and reflash it.

What are your 5ghz settings? (I use channel 44 with 80mhz and wpa2 encryption) I wanted to try a higher channel, I also don't have wifi interference nor is the router itself restarting. I'll try what I said above first and if still getting problems, I'll reflash to stock and see if its hardware related like I said. I haven't done that because others in the house use the net and any downtime atm might mean I'll be killed lol


#1174

Nothing special.
Encryption: WPA2 PSK (Force CCMP)
Channel: 36 (5.180 GHz)
Width: 80 Mhz

I read that using a lower channel is better, unless many wifi networks are using that channel. So scan and see what the lowest less crowded channel is.

And it might be hw related like you said, check thermal graphs, might give you a hint.
Mine is currently about 52-54C


#1175

I used channel 149 without any problems as I've got a tri-band EX7500 extender upstairs that suggests going high and it going low.


#1176

@hnyman any thoughts on including kmod-ipt-filter?


#1177

I installed Oracle VM Virtualbox, then installed Ubuntu 18.04 as a virtual machine. Follow the instructions in the first post of this thread. hnyman explains how to make your own build environment, then your can build your own image with any package, kmod you desire.
Use the "make menuconfig" to add or subtract packages. I needed kmod-usb-net, kmod-usb-net-rndis, kmod-usb-net-cdc-ether. Which hnyman did not want to include, because he does not need them. I needed them for USB tethering.
Works great.
Have fun!!


#1178

Might try that. However I think netfilter modules are useful for everyone now when we have slightly more onboard space available.

EDIT: Can I just build it as a module and use it or do I need to recompile everything? Takes quite some time it seems.
Figured it out but for some reason I got a kernel mismatch:
Installing kmod-ipt-filter (4.14.67-1) to root...
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ipt-filter:
  •  kernel (= 4.14.67-1-05368decf48cc126993e9c1932baf284) *         kmod-lib-textsearch *
    
  • opkg_install_cmd: Cannot install package kmod-ipt-filter.

Running:
Linux nighthawk 4.14.67 #0 SMP Wed Aug 29 14:13:05 2018 armv7l GNU/Linux


#1179

Just like I had to learn.

Quote from hnyman "You can't install kmods into private builds due strict kernel checksums"


#1180

I am trying to compile this build using your scripts with the only change of selecting the no-ip.com script in addition to the normal dynamic dns. I just downloaded the latest patches for master, and used thhe new buildroot script to create a fresh build system. I have been successful with this in the past, but am now encountering an error. After it failed the first time, I ran it again with single compile and got the following error:

make[3]: *** [/Openwrt/master/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/linux-ipq806x/base-files/.configured_4d5248d1a6ded9ff903db6e28899f202_8e081b74cf069e1e6800a5bbcbb282f0] Error 255
make[2]: *** [package/base-files/compile] Error 2
make[1]: *** [/Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/stamp/.package_compile] Error 2
make: *** [world] Error 2

Here is the end of the build.log file:

make[3]: Entering directory '/Openwrt/master/package/system/openwrt-keyring'
mkdir -p /Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/root-ipq806x/stamp
SHELL= flock /Openwrt/master/tmp/.root-copy.flock -c 'cp -fpR /Openwrt/master/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/openwrt-keyring-2018-05-18-103a32e9/.pkgdir/openwrt-keyring/. /Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/root-ipq806x/'
touch /Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/root-ipq806x/stamp/.openwrt-keyring_installed
echo "openwrt-keyring" >> /Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/pkginfo/openwrt-keyring.default.install
make[3]: Leaving directory '/Openwrt/master/package/system/openwrt-keyring'
time: package/system/openwrt-keyring/compile#0.21#0.04#0.34
make[3]: Entering directory '/Openwrt/master/package/system/usign'
mkdir -p /Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/root-ipq806x/stamp
SHELL= flock /Openwrt/master/tmp/.root-copy.flock -c 'cp -fpR /Openwrt/master/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/usign-2015-07-04-ef641914/.pkgdir/usign/. /Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/root-ipq806x/'
touch /Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/root-ipq806x/stamp/.usign_installed
echo "usign" >> /Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/pkginfo/usign.default.install
make[3]: Leaving directory '/Openwrt/master/package/system/usign'
time: package/system/usign/compile#0.29#0.07#0.43
make[3]: Entering directory '/Openwrt/master/package/base-files'
rm -f /Openwrt/master/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/linux-ipq806x/base-files/.configured_*
rm -f /Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/stamp/.base-files_installed
[ -s /Openwrt/master/key-build -a -s /Openwrt/master/key-build.pub ] || /Openwrt/master/staging_dir/host/bin/usign -G -s /Openwrt/master/key-build -p /Openwrt/master/key-build.pub -c "Local build key"
[ -s /Openwrt/master/key-build.ucert ] || /Openwrt/master/staging_dir/host/bin/ucert -I -c /Openwrt/master/key-build.ucert -p /Openwrt/master/key-build.pub -s /Openwrt/master/key-build
Makefile:205: recipe for target '/Openwrt/master/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/linux-ipq806x/base-files/.configured_4d5248d1a6ded9ff903db6e28899f202_8e081b74cf069e1e6800a5bbcbb282f0' failed
make[3]: *** [/Openwrt/master/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/linux-ipq806x/base-files/.configured_4d5248d1a6ded9ff903db6e28899f202_8e081b74cf069e1e6800a5bbcbb282f0] Error 255
make[3]: Leaving directory '/Openwrt/master/package/base-files'
time: package/base-files/compile#0.11#0.01#0.17
package/Makefile:107: recipe for target 'package/base-files/compile' failed
make[2]: *** [package/base-files/compile] Error 2
make[2]: Leaving directory '/Openwrt/master'
package/Makefile:103: recipe for target '/Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/stamp/.package_compile' failed
make[1]: *** [/Openwrt/master/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/stamp/.package_compile] Error 2
make[1]: Leaving directory '/Openwrt/master'
/Openwrt/master/include/toplevel.mk:216: recipe for target 'world' failed
make: *** [world] Error 2

Any idea what the issue here is? Any help would be much appreciated.


#1181

No idea yet. Looks like basefiles configure step fails, but your log shows no actual error.

There was trouble with usign a few weeks ago, but that got fixed.


#1182

That's why I compilet it myself thinking it would work like you said. But maybe you flash the entire image?