Build for Netgear R7800

I only build for devices that I have.

I build this for ipq806x R7800.
And then I have a separate community build for ar71xx WNDR3700v1/v2/3800

I also have a mvebu WRT3200ACM router and I build LEDE for it, but I have not started to publish the build.

There's new tcp congestion control algorithm in k4.9 called BBR, you may want to use it in your builds
http://blog.cerowrt.org/post/bbrs_basic_beauty/

I have not tried it yet, but based on earlier discussion in TCP BBR support it sounds like it brings most benefits for the bulk traffic originators (like youtube servers etc.). I am not sure if it would bring significant benefits to home routers.

But I will follow the discussion.

It should be a common effort I suppose.
A while ago I've been testing different congestion algorithms in my local isp environment and I've had different results even on a client side (I've been testing with downloading Linux images with torrent) opposing to common view that it's a server-side mechanism.
At that time YeAH gave me the best result.

I've repeated tests and BBR tend to give me same results.

But in any case it will surely be useful for WiFi client devices with low signal while using online streaming services: video, voip and such.

lede-r3888-8fb39f1682-20170328

Fallout from kernel 4.9 bump has been largely fixed. The fix proposed by me has been committed to the main repo as https://github.com/lede-project/source/commit/c69a89fe23a526ec3eef9c4e63eb672387e5177e, so wifi should again work out of the box for all builds.

1 Like

First of all, thank you for your great work on the R7800, hnyman! :slight_smile:
I wanted to buy this router to turn it into a VPN router. So I just have three small questions regarding it:

  • What speeds can I achieve with the OpenVPN client? Since it has this powerful cpu, I hope for 60-70mbps.
  • Does the latest build I can download include the kernel 4.9?
  • Does LEDE come with a DNLA server built in?

Best regards,
layentara

I have not used OpenVPN, so no answer to that. (You might get better answers in the generic "R7800 exploration" thread instead of this build-specific thread)

kernel 4.9 is in the newest builds

No built-in DLNA, but there are packages available for that, e.g. minidlna. No experience from using them.

Thanks hnyman, I will ask in that thread again :slight_smile:

I will remove aiccu in the next build, as SixXS will stop operations in June.
https://www.sixxs.net/sunset/

[quote]Sunsetting SixXS

SixXS will be sunset in H1 2017. All services will be turned down on 2017-06-06, after which the SixXS project will be retired. Users will no longer be able to use their IPv6 tunnels or subnets after this date, and are required to obtain IPv6 connectivity elsewhere, primarily with their Internet service provider.[/quote]

If you are still using aiccu-based SixXS 6in4 tunnels, start looking for alternatives...

Hello hnyman

how do i get back to stock?

Easiest way is probably to use the TFTP recovery flash process, whick is described in Netgear R7800 exploration (IPQ8065, QCA9984)

I tried this way, the flash process stops everytime at 75% and says that server doesnt response. If i try to flash your build it works.

I am not sure if I have ever tried to flash back to OEM stock firmware with R7800 but it should work ok with the TFTP recovery mode.

This is pure guess, but if you have not set a fixed IP address to your PC from 192.168.1.X subnet, it is quite possible that the DHCP client in your PC tries to renew address during flash, fails, and changes IP address in the middle of a flash to a link-local 169.254.x.x address and that causes TFTP to fail. Windows PCs are especially eager to change IP rather quickly. (I have experienced that several times when I have been lazy with R7800 or WNDR3700 and have not changed to a fixed IP before the TFTP flash. then the TFTP transfer stops in the middle.)

I have used the TFTP2 GUI client, which makes it rather easy to prepare the TFTP transfer in advance before triggering the recovery mode.

I have flashed back to stock the way hnyman mentioned several times from my MacBook. Usually a smooth and simple process once you set a static IP and ensure your firmware is in the correct spot. Firmware transfers over in about 4.7 seconds, then restarts into the Netgear page.

Yes i did set a static IP address. But it doesnt work.
I tried to install it through putty with the command sysupgrade -n -F. This results in a bootloop. I could fix the bootloop by flashing LEDE over TFTP, but the stock one breaks at 75% everytime.

which tftp client do you use?

Hi, With the latest service release of LEDE, are there code/patch differences between this one and the standard build?

On Mac, I place the netgear fw in my user home folder, then in Terminal (I am sure the process is the same in putty), I run these commands:

tftp
connect 192.168.1.1
binary
rexmt 1
timeout 60
put R7800-V1.0.2.28.img

This moves the fw to the router and begins flashing the router.

[quote="Spots, post:95, topic:316"]
I tried to install it through putty with the command sysupgrade -n -F. This results in a bootloop.[/quote]
Sure. In most devices you can't install the OEM image via sysupgrade. That holds true to R7800, too. (The few devices where you can do that (like wrt1900ac series), are exceptions,)

[quote="Spots, post:95, topic:316"]
I could fix the bootloop by flashing LEDE over TFTP, but the stock one breaks at 75% everytime.
[/quote]Sounds strange as the the whole TFTP functionality is in the OEM bootloader (u-boot) that is not modified by LEDE or Openwrt. LEDE (or Openwrt) firmware has no role in the TFTP recovery flash. So, OEM firmware images should be compatible with OEM TFTP flash routine...

Like I said above:

Yes. The changes are pretty much about tweaking some LEDs, config settings etc. to match R7800 better. Full diffs are available in the download directory as patch files, just like I say on the first message of this thread:

Hi,your build Firmware for R7800 is very good,but when I command line 'opkg install iptables-mod-tproxy',install fail,do you know what is happen,how can I fix it to install?Thank you!