Build for Netgear R7800

At the moment there aren't any major special tweaks, mainly just the extra packages included, and their default settings adapted to R7800 (e.g. SQM interface is eth0.2 instead of the (old) global default eth1.)

In the early years there were more R7800 specific tweaks and experimental/development stuff, but those have already been incorporated to the main OpenWrt.

1 Like

For me the main benefit of hnyman's builds is being able to run master builds to stay close to the current development of openwrt. It's much more convenient and safer than running development snapshot builds directly because hnyman's builds are tested on R7800 before upload, and common convenient packages like the LuCI web UI are included by default instead of having to manually install them.


I haven't quite kept up, how far off do we believe the transition to DSA as the default is for these builds?

The PR exists and is working, (aside from a trivial rebasing-) it just needs to be merged into master. That happens at the courtesy and schedule of the project developers, but there's no reason why it couldn't happen today, tomorrow, in six weeks or may take longer. For obvious reasons it won't make it for openwrt-21.02, but it should be merged well in advance before the next stable release gets branched off.


Thanks! Here's hoping it makes its way into master soonish.

If you have the time, would you consider testing this patch please @hnyman ?

Symptoms should be that 160MHz won't start on ath10k-ct (master or 21.02).
After patch, should start (after CAC timeout).

I might test it, but as I remember the 2019 discussion, I would have thought that greearb had fixed it at that time (as he said in )

Best might be to look at sources at the -ct repo, and point the missing fixes to greearb.

1 Like

It is missing from 5.10, 5.11, 5.12 kernels in the repo. I'd rather someone tested it first before i send it to him but i can do it if no one is volunteering.
No pressure only if you had time and were doing a build anyway :slight_smile:

I tested that patch, and it seems to help R7800 to start the VHT160 DFS scan, but not without problems. My clients detected VHT80, and I received DFS related crashes.

1 Like

Appreciate that thank you. A step in the right direction, but there's obviously some deeper issue as well. Im no good at reading kernel dumps.

suddenly my r7800 on previous 19.07 didnt boot after a reboot, followed by a few reboots and i noticed the power led kept blinking
i then reset it and the orange led kept blinking for a min or two. shouldnt it resume to normal and boot up after a reset automatically?
anyway i have powered it off and on finally and now it booted up successfully
dono what happened actually, i will take a look at the logs
this is the first time since i switched to r7800 around 1.5 yrs ago
any ideas?

"Reset" is a software thing. There is no actual hardware reset. If the OS was stuck, your reset probably did nothing or did something set by the bootloader that knows nothing about OpenWrt. (the OpenWrt reset works when the router is normally running, so that the scripts for the software reset can be run.)

They will likely tell you nothing, as the logs are normally in RAM, so nothing survives a reboot.

Weak power source?

yeah i know, but i thought it will earse the data and then reboot the router or do a clean start up after a reset . coz in the faq, it says try to connect to the router after reset by plugin the cable , so....

i want to see if there are any bad blocks etc in the log file

no, it shouldnt be a power issue

Hi @hnyman
Are you able to test your kernel 5.10 DSA build with VLANs? I had the following setup:

R7800                    R7800
 DHCP ----802.1q trunk----dumb
router                     AP

The result is like Ethernet switch on VLAN enabled router is misbehaving. At the same time VLANs aware dumb AP is working fine. After swapping R7800 router with AX3600 with the same (in general) config everything works as it should.

DDNS worked 8+ days ago - only had a short time to setup for another location so it's been powered off during this time. Turned the R7800 back on today to finish setup for the network and noticed DDNS showed never/stopped for enabled ipv4. 8 days ago, it showed timestamps for last/next update ( Now it shows never/disabled. Error in the log is below. Any suggestions on how to get DDNS working again?

user.warn ddns-scripts[7338]: myddns_ipv6: PID '7338' exit WITH ERROR '1' at 2021-07-31 21:41
user.err ddns-scripts[7337]: myddns_ipv4: IP update not accepted by DDNS Provider

Hey guys. Brand new user here. Got the build up and running. Enabled SQM using cake/poc on eth0.2 and download speeds have gone from 400mbs to around 20mbps. I know to expect some reduction but is that much normal?

No, it is not normal.
Some config error in your settings, probably.

Mmh, please post your /etc/config/sqm in a new thread and we can take it from there...


Unless it requires lots of effort, is there any chance @hnyman that the 19.07 branch of your build is updated at least to the latest available version r11364 ? :

I softened and did one more 19.07 build with r11366-cfc1602a1e

But as the network config has already changed between 19.07 and 21.02, downgrading is not that easy, and I have to modify my own config, which makes downgrading cumbersome. I have also noticed that I have got some "ubi bad superblock" errors with the last few 19.07 downgrades, so I have lost my config several times, also today. So, this is definitely the final time with 19.07...

The 21.02 final release will get released soon, so there is no real need to stay with the ancient 19.07.