Build for Edgerouter-X — not booting up

After building from snapshot router fails to boot, I even tried ImageBuilder, and same outcome. Any advise? If I try to install a sysupgrade image from snapshot after flashing a LEDE initramfs it fail saying that device is not compatible too.

I am at lost here. Any help will be really appreciated.

You can/should not flash those initramfs images; they're meant to be run from RAM (hence the name). Snapshot might have different naming for Ubiquiti devices, and mt7621 (if that's the hardware you have) has seen a kernel bump to 5.4 with some hiccups (yours might be suffering as well).

Did you try a 19.07.2 image? Those should work at least.

Hi, @Borromini,

I am not trying to flash initramfs, that's precisely the only thing I did not tried. :slight_smile:

What I am doing is trying to sysupgrade from 19.07.2 to snapshot. I am sure that the upstream of the kernel to 5.4 introduced some hiccups along the way; however, there are people running it. So, that's why I am trying to do it. I want to get rid to some of the DSCP rules I have and use the new iptables --dscpsave option, and for that I need our new and shiny kernel 5.4 and new iptables binaries. I see that the buildbot is not compiling snapshots anymore, which makes it suspicious to me.

Thanks for your advise in any case.

OK :slight_smile:

If you have the right image you can try with a sysupgrade -F. I think commit e8931b309f is causing issues here.

I tried the --force option too, no luck, mate.

Did you check the wiki?

Sure I did. That is not the problem. I've have a LEDE factory image that I use to flash initramfs and after I install the official release and all good. If I choose to install the compiled snapshot of the image of the one created with ImageBuilder in place of the official release it does not work. That's what is driving me nuts.

Can you use serial? That would help to see where things go wrong.

1 Like

Just to make sure: You are NOT keeping settings when flashing, right? Because due to a switch to the dsa driver, old settings are NOT compatible and can cause bootloops. Make sure you configure it as fresh.

1 Like


I WAS keeping settings. I will try with sysugrade -n, thanks for the advise.

5.4 brings DSA on ramips (and other platforms). You have a 5.4 kernel now that doesn't know what to do with the swconfig settings from 4.14. Keeping settings is a bad idea (as it generally is when you're flashing hopping 'channels', so to speak).

@Borromini, @Mushoz, my bad, I never thought of that. I will let you know how it goes this arvo!

@Mushoz, @Borromini, now as soon as I define

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '0'

in /etc/config/network it stops booting up. And if I keep my whole lan in a bridge with all ethX ports, it does not get connection to my ISP using DHCP. Any ideas or examples of a network configuration file using new DSA architecture? I suspect that this is my problem now. :slight_smile:

Like I said: switchconfig does not apply anymore. Your devices are now lan1-4 and wan afaik. You cannot put back old /etc/config/network stuff back, at least not for the LAN/switch parts.

LuCI doesn't support DSA yet either from what I gathered.

Yes, I know. I just tried, I did not realise this was different. In any case I was not able to bring up the WAN interface. So, I am taking another route. Thanks for your help, @Borromini.

1 Like

I use this working network config in my edgerouterX based on kernel 5.4 ...

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '64'
	option ifname 'eth0 eth1 eth2 eth3'

config interface 'wan'
	option ifname 'eth4'
	option proto 'static'
	option ipaddr ''
	option gateway ''
	option netmask ''
	option ip6assign '64'
	option force_link '0'

config interface 'wan6'
	option ifname 'eth4'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

Is VLAN support coming back anytime soon that you know of? DSA is all fine and dandy, but this seems like a few too many steps back.

I have no idea about that, sorry. DSA is what upstream Linux is pushing. I thought blogic had a patch for it but might be mistaken.

Edit: I got pointed to these patches on IRC.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.