Bug wIth last compilation: no WPA2 only WEP

With old compilation no problem

YouHua WR1200JS
MediaTek MT7621 ver:1 eco:3
OpenWrt SNAPSHOT r8410-900005ee75 /LuCI Master (git-18.306.47163-21d7dfe)
Version du noyau
4.14.78

**no problem i can **configure with WPA WPA2 ** **

--
With the new compilation ( git pull, … feeds … )

YouHua WR1200JS
MediaTek MT7621 ver:1 eco:3
OpenWrt 18.06-SNAPSHOT r7389-4db74fbd69 /LuCI openwrt-18.06 branch (git-18.318.52383-44f91bb)
Version du noyau
4.14.81

I have only WEP possibility not WPA WPA2

why ?

One of these things is not like the other. (Master / 18.06) ?

I think that i have run git checkout openwrt-18.06

git log -1 --pretty=medium

git log -1 --pretty=medium
commit 3a6bddd7f75f130ff7c6819073ee7f61f44696b6
Author: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Date:   Mon Nov 12 22:46:13 2018 +0000

    hostapd: add utf8_ssid flag & enable as default
    
    SSIDs may contain UTF8 characters but ideally hostapd should be told
    this is the case so it can advertise the fact. Default enable this
    option.
    
    add uci option utf8_ssid '0'/'1' for disable/enable e.g.
    
    config wifi-iface
            option utf8_ssid '0'
    
    Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>


That's master and HEAD of the OpenWrt repo right now. openwrt-18.06 is a different commit:

$ git log -1 --pretty=medium origin/openwrt-18.06 
commit 4db74fbd6908db88eda4227ed3d18822c80b9ea1 (origin/openwrt-18.06)

Ok
I redid a new virgin complilation:

new folder
git clone https://www.github.com/openwrt/openwrt
scripts / feeds update -a
scripts / feeds install -a

this time I have a proper functioning:

YouHua WR1200JS
MediaTek MT7621 ver:1 eco:3
OpenWrt SNAPSHOT r8459-3a6bddd7f7 /LuCI Master (git-18.318.72220-6bc04b6) 
4.14.81

thank you for envying a little crazy!

--
one more question:
would you know how I can configure OpenWrt to be able to use the box in WPS (not in WDS) ?
I can not bind this one with my box Orange who only WPS

i have found options with : wpad and hostapd but i cannot run the WPS button
there is not a lot of information on the subject
the case has a WPS marked button a bit like this picture

RT-AC1200

In the future, please make another thread in the appropriate section.

https://openwrt.org/docs/guide-user/hardware/hardware.button