BUG REPORT : zlib dynamic references missing?

We found a problem on zlib, and looks like on all shared libraries, when debugging pyinstaller package...

How can I report a bug/issue in OpenWrt ?

See https://openwrt.org/bugs

OpenWrt does not support on-target compilation. You can't link the system zlib due to OpenWrt using sstrip which agressively strips symbol table information from shared objects which makes them unsuitable for linking.

This isn't really a bug that can be solved but rather a consequence of a deliberate design decision (agressivly strip binaries to save space).

There's several solutions:

  • compile and install non stripped zlib on-target as well
  • rebuild your OpenWrt image without CONFIG_USE_SSTRIP
  • fix pyinstaller's (?) build system to only consider the system provided libz if it is linkable

It is what I think ... thanks for the precision...

So useless to open a bug report !

I can also try to make a package to the problematic python package... and offer it for upstream !
A corrective solution is already proposed by the team of pyinstaller, and may help to fix the specific package installation issue...
I was wondering about others package which still get errors with linking libs...

I can still try crooscompile and packaged them...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.