[bug] Changing channel in OpenWrt disables 5GHz band wifi

I hace changed 80mhz to 100 and than 120 find wifi disabled after applied
Mi4a gigbitit it is hopefully a bug

What are those numbers ?

Channels ?
Width ?

As @frollic asked... what are these? And how are you changing them? You can theoretically set invalid numbers if you use the CLI and/or direct editing of the config files, but LuCI shouldn't allow you to set anything that isn't valid.

If they are the channel width, the options available are 20MHz, 40MHz, 80MHz, and 160MHz. 100 and 1120i would be invalid.

If you've set 80MHz channel width and are then changing the channels themselves, keep in mind that you cannot arbitrarily set the channel if you're using anything >20MHz because of the way they are allocated... for example, an 80MHz width set with center channel 106 occupies channels 100-112. You can't select, for example, channel 104. See the table of 5GHz wifi channels for a visual about how this works. (it is possible that LuCI will let you set an invalid channel under these circumstances).

Channel Width: is default 80 i have not changed that
Channel chnaged to 120 see in this screenshot.
But after save wifi showing disabled and i can't see wifi then i connect a ethernet and set it to auto or 36 and then it again started working what is wrong

Same happened when i set it on 2.4g on 13 channel it stop working i mean disabled so i need to again set that to auto and ut started working again. If i have done something wrong or it was a issue in firmware i think it maybe a bug.

try to change contry code 00 to a different one

1 Like

I have chnaged it to india as i am in india

i see 00 in the screnshot you posted

1 Like

Make sure those channels are available in your country, then check if they are DFS channels.

1 Like

What is dfs what will happen if i select them

Search is your friend... DFS.

In short, if you use a DFS channel, the radio must (by law) shut down if it detects radar. You can see a a list of wifi channels and the DFS status (by region/country) in the link I shared previously:

1 Like

Okey now which channel should i switch to i have a reference that i have a tplink c6 device i can see some some channels are only in the list so if that is the reference i should follow.

I would recommend selecting a channel that is legal in your country (be sure to set your country code) and one that is not in the DFS range.

I don't recall how OpenWrt handles the situation of a non-center-frequency selection when you're using 40MHz+ channel widths, but as I think about it, I think it will just internally use the correct center frequency. Maybe someone else can confirm or refute that.

In that case i think setting the country will sort out that frequency spectrum which are allowed in that country if that can be implemented i hope it can be a really good feature as well as a bug fix.

I'm not exactly sure what you mean by this:

Setting the country code ensures that your router will only use channels that are legal in your region. Not setting the code will end up with the most restrictive set of channels. And setting it to the wrong country will result in potentially out-of-compliance operation which is illegal and may actually cause harm in your area (as that bandwidth is typically allocated for other uses such as government/military/first-responders or even other private industry use).

1 Like

tp-link devices 5ghz and 2.4ghz options are here

when we set up the country openwrt wireless channel option should only show this specific channels it will reduce failure and other issues.