Bt homehub 5 business 20mb out of 200mb

So i got my homehub 5 type a Lede is installed i have everything working wifi is fine lan connections are fine but the speed isnt
its running behind the cr*ppy Superhub 3 in modem mode running through a NEW cat 6 cable to the wan port on the home hub but my connection is a 200mb down and 20mb up which i get if i connect my laptop direct to the superhub in modem mode but as soon as i put the homehub in it drops to between 20 and 40 mainly around 20.
ive tried different cables ive tried resetting and starting again no luck, i read somewhere someone had similiar issues with an asus router where the wan port wasnt reading the connection as a gigabit but as a 100mb but his fix didnt work and im only able to use the luci as im not versed enough in linux to mess around with telnet and putty without an obvious guide.
any ideas what the cause could be or what fix i could try. i havent installed sqm either

The type A has a Lantiq PSB 80910 processor at 500Mhz. I don't think you're ever going to get 200mbit out of it, but you might get more like 50 or 70, so I think 20 is indication of a real problem.

Are you testing with a wired connection to the router? make sure you're not testing with wifi.

bufferbloat can cause slowdown by starving connections of the ACKs they need.... so it's worth a shot evaluating your connection speed and bufferbloat on dslreports to see how much that might be affecting you.

Probably someone who has more familiarity with this hardware will come along and give you suggestions about what speeds they actually achieve in practice.

ive tested with both wired and wifi and achieved the a steady 30 on wired and 20-40 on wifi
how would i go about evauluating the bufferbloat without installing sqm?, i was hoping to get around 100 out of 200 at least....seems like i need a more powerful router anyway then. i was pointed in this direction by a friend who has the same setup but he is getting a steady 50-55mb's and he is only on the 55mb package

is what I use here.

The wiki quotes ~72 MBit/s using the VDSL2 modem, my own tests with master and kernel 4.14 showed ~84 MBit/s. With flowoffload enabled, I can achieve ~94-96 MBit/s (which is line speed, so I can't test beyond that - Hardware NAT For LEDE suggests the hard cap to be around 120 MBit/s with flowoffload right now). The VRX268 SOC is definately put under quite some load (making throughput occassionally a bit spiky) while routing at those speeds and it won't go much further without hardware acceleration (which isn't available to LEDE). Doing sqm on top or expecting VPN throughput to cope certainly won't be possible, but plain PPPoE/ NAT/ adblock etc. certainly works with 100 MBit/s VDSL2/ vectoring thanks to flowoffload.

I have not tested throughput of the red WAN (1 GBit/s ethernet) port so far, but given that the BT Home Hub 5 type A offers a pretty good vectoring capable VDSL2 modem, it makes no sense not to use- and operate it behind another VDSL modem (I would certainly remove it from the setup for testing/ banchmarking to check for the bottleneck, a 20 MBit/s cap might suggest a fallback profile being in use (e.g. because of a non-vectoring capable VDSL modem)).

Edit: Searching for "SuperHub 3" suggests a cable modem, then you obviously can't use the VDSL2 modem of the BT Home Hub 5 type A.

According to the Section 7.12 of the Bill's manual, the WAN to LAN throughput measured in stable LEDE 17.01.4 is about 50mbps, while LAN to LAN throughput is 900mbps. While I do not fully understand the reasons behind it, it is clear that 20mbps probably can not be due to hardware or firmware limitation of HH5a. You may be able to fix / mitigate / explore the issue by re-designating one yellow LAN port as WAN port, which will require to change the Switch settings.

Another usual recommendation is to disable dsl_control package if you are not using the DSL port. This is because in absence of the DSL signal the dsl_control daemon is reported to waste a lot of memory / CPU cycles and eventually lead to instabilities and reboots. Disabling it seems to fix this problem.

You may also find you're hitting a similar bottleneck to the one mentioned a few minutes ago on this thread over here:

adjusting sysctl settings to increase the packet budget for each poll could be advantageous.

Connections between LAN ports never leave the switch, they don't need to pass through the CPU and get processed there, this should give you line speed (1 GBit/s).

As a router, the traffic needs to pass through the CPU (handling PPP(oE), NAT and firewalling), here the throughput depends on the ethernet connection between SOC and switch and (with slower CPUs) also on the performance of the CPU itself. Mips has traditionally offered relatively fast I/O, but rather slow CPU performance - in the days of ADSL this wasn't much of a problem, but in recent years this has become a bottleneck (which is one reason why the router market is moving towards ARM).

Redefining a LAN port as WAN port is possible, but it won't improve performance (all ports are connected to the same switch, the connection to the SOC only uses one -the same- PHY).

@slh While I understand and appreciate your explanation, it still can not fully explain the bottleneck at 20 mbps observed by @talon23. Neither (I think) can it explain the 50mbps bottleneck observed by @bill888. If the limitations were due to slow CPU performance, we would never reach 60+ mbps via VDSL2 on this router.

First of all, check LAN to WAN by plugging a computer into the WAN, setting an IP address, setting the HH to static IP and then another computer plugged into the lan. Download iperf and run it to get your LAN to WAN speed.

It'll probably not be massive since the HH5 has a fairly anemic processor (it's only provided for accounts up to 80Mbps down).

Your only real options then are looking at doing a custom build with the Qualcomm FastPath patch, or buying something more up to the job.

As for why the stock firmware gets better throughput, Hardware acceleration would be the answer.

ok so i did some messing about and plugged a lan cable from the superhub to the hh lan to lan changed nothing on the settings superhub is in router mode not modem mode and im getting full speed through the HH
going to try in modem mode shortly and will update

All VRX200 devices that i know are describe to 100Mbit/s limit in datasheets.
(one Easybox 904xDSL is limited to 50Mbit/s)

LEDE remains under these possibilities one reason can be missed SMP support an other reason that i guess is missed PPE
See the last post in this thread

Got it running now at 60 down 12 up without hardware acceleration or better knowledge thats gnna be the highest i get it i reckon

On VDSL-NAT-Router with the same chipset, I get equal rates on 1 core, with SMP support up to 92Mbit/s.
When you do the messurments stop looking (calling) webif and stop ssh access it cost ~10MBit/s extra.

what is the output from

cat /proc/cpuinfo


Which LEDE version do you have ?
On newest snapshot SMP support should work.

What is your VDSL plan ? and which rates do have in normal ?

If CPU capable of 60mbps down, then CPU is capable of 60mbps up, unless you have an exotic config, which seem not to be the case. So whatever the problem is, it does not seem to be due to hardware limitations of HH5a. Could it be some traffic management on your modem, e.g. SQM or DLM?

I don't know what is your desired configuration, but maybe you could keep your Superhub in the router mode but disable / ignore wireless and set your LEDE HH5a as a dumb wireless access point using a yellow LAN port? This will give you maximum speeds, but all the routing will be done on Superhub, so you probably won't be able to fully use LEDE's advanced functions.

You can have much higher speeds with flow offloading enabled: How can flow-offloading be enabled on lantiq xrx200 devices?