BT Home Hub 5A Recover LEDE v17.01.4


I have purchased a BT Home Hub 5A router off eBay which is running LEDE v17.01.4. After the router had been rebooted I was no longer able to login to the UI using the default gateway IP in a web browser.

I am how ever, able to enter fail safe mode in putty via SSH but running the following commands does not reset my routers default settings it just retains my damaged config.

LEDE Failsafe mode

Can I re-flash my router from within fail safe mode?

The router only has the WiFi LED lit blue and the broadband LED is not lit up on the front of the router when its finished its boot sequence.

Thanks for the advice in advance :slight_smile:

Soft Factory Reset -[]=failsafe#soft_factory_reset

Hard Factory Reset -[]=failsafe#hard_factory_reset

...and yes, you can sysupgrade from failsafe.

Didn't work.

Soft Factory Reset -[]=failsafe#soft_factory_reset1

Hard Factory Reset -[]=failsafe#hard_factory_reset2

How do I syspgrade from failsafe mode?

See this OpenWRT link...

Thanks I hope this works.


This is a screenshot of the routers /tmp folder. I have copy the firmware file which has the name lede-17.01.4-lantiq-xrx200-BTHOMEHUBV5A-squashfs-sysupgrade.bin.

The IP Address of the router is The IP address of my local PC is

router SSH

Here is a screenshot of the SSH connection on the router. I first cd into the /tmp directory to show where the firmware is located.

In then ran the following command nc 3333 > /tmp/lede-17.01.4-lantiq-xrx200-BTHOMEHUBV5A-squashfs-sysupgrade.bin.

This didn't do anything. so I tried the windows method.


First I navigated to the downloads folder on my PC the I cd into the nc111nt folder were netcat is installed.

I then ran the command nc -l -p 3333 < lede-17.01.4-lantiq-xrx200-BTHOMEHUBV5A-squashfs-sysupgrade.bin

This didn't work also, what am I doing wrong here.



Should be the IP of your computer...

However, in WinSCP, it looks like you already have it copied to /tmp, so continue the OpenWRT instructions at the install firmware with current settings section.

So the IP address of my local PC should be

Do I run the following command in windows cmd as follows?

nc -l -p 3333 < lede-17.01.4-lantiq-xrx200-BTHOMEHUBV5A-squashfs-sysupgrade.bin


No...the IP address should be the current IP of your computer when running nc on the router command line.

No...the Windows command is different.

Both the router and Windows nc commands are to copy the firmware file to /tmp. It doesn't flash the firmware.

You have already done the copy using WinSCP.

As mentioned before, continue with the OpenWRT instructions.

So the next command I run from putty, which is connected to the router should be.

nc 3333 > /tmp/lede-17.01.4-lantiq-xrx200-BTHOMEHUBV5A-squashfs-sysupgrade.bin

The IP is my PC not the router.


You're not listening...the nc command is used to "copy" the firmware to the router.

The WinSCP screenshot you posted shows you have already done that...

The next command you should run is in the OpenWRT instructions settings section "install firmware with current settings". Scroll down to that location on the page.

sysupgrade /tmp/the firmware name you used

If you have ssh access and putty, just use pscp (from the same source as putty itself) instead.

The firmware is already in /tmp.

I ran

root@(none):~# sysupgrade /tmp/lede-17.01.4-lantiq-xrx200-BTHOMEHUBV5A-squashfs-
Image metadata not found
Use sysupgrade -F to override this check when downgrading or flashing to vendor firmware
Image check 'fwtool_check_image' failed.

So the ran

root@(none):~# sysupgrade -F /tmp/lede-17.01.4-lantiq-xrx200-BTHOMEHUBV5A-squash
Image metadata not found
Image check 'fwtool_check_image' failed but --force given - will update anyway!
Saving config files...
killall: watchdog: no process killed
Failed to connect to ubus

Enter the following commands in the router command line - one at a time...

ubus listen &

ubus call network.interface.wan down

ubus call network.interface.wan up

okay cheers


So when you got the "failed to connect to ubus" message when using sysupgrade -F , did you kill the sysupgrade, or did it die on its own?

I would have expected to see something like...

Failed to connect to ubus
Switching to ramdisk...
Performing system upgrade...
Unlocking firmware ...

The sysupgrade -F die on it's own.