BT home hub 5 can't find kernel

I'm just about to trash a HH5a. After following the instructions for installing LEDE sucessfully I tried to sysupgrade to the latest openwrt but ended up with an error message of unable to find image. On boot I now get this

ROM VER: 1.1.4
CFG 06

DDR autotuning Rev 0.3d
DDR size from 0xa0000000 - 0xa7ffffff
DDR check ok... start booting...

U-Boot 2010.06-LANTIQ-v-2.2.46 (Sep 07 2013 - 02:57:04 on tester@clean-machine)

secure boot
DRAM:  125 MiB
NAND:  NAND device: Manufacturer ID: 0xec, Chip ID: 0xf1 (Samsung NAND 128MiB 3,3V 8-bit)
128 MiB
Bad block table found at page 65472, version 0x01
Bad block table found at page 65408, version 0x01
nand_read_bbt: Bad block at 0x000002ae0000
nand_read_bbt: Bad block at 0x000007be0000
In:    serial
Out:   serial
Err:   serial
Net:   Internal phy(GE) firmware version: 0x841b
vr9 Switch

Type "run flash_nfs" to mount root filesystem over NFS

Hit any key to stop autoboot:  0
Creating 1 MTD partitions on "nand0":
0x000000100000-0x000007fc0000 : "mtd=0"
UBI: attaching mtd1 to ubi0
UBI: physical eraseblock size:   131072 bytes (128 KiB)
UBI: logical eraseblock size:    129024 bytes
UBI: smallest flash I/O unit:    2048
UBI: sub-page size:              512
UBI: VID header offset:          512 (aligned 512)
UBI: data offset:                2048
UBI: attached mtd1 to ubi0
UBI: MTD device name:            "mtd=0"
UBI: MTD device size:            126 MiB
UBI: number of good PEBs:        1010
UBI: number of bad PEBs:         4
UBI: max. allowed volumes:       128
UBI: wear-leveling threshold:    4096
UBI: number of internal volumes: 1
UBI: number of user volumes:     4
UBI: available PEBs:             8
UBI: total number of reserved PEBs: 1002
UBI: number of PEBs reserved for bad PEB handling: 10
UBI: max/mean erase counter: 2081/1622

Looking for active section/image:
  0. section: type:8 not an image
  1. section: type:9 not an image
  2. section: type:1 not an image
  3. section: type:3 not an image
  4. section: type:3 not an image
  5. section: type:2 image. reading section header @0x140e76c...
OpenRG volume not found
ubi_volume_read failed; read -19
header read failed!
  6. section: type:2 image. reading section header @0x281cf6c...
OpenRG volume not found
ubi_volume_read failed; read -19
header read failed!
  7. section: type:7 not an image

Verifying image(s):
No active image found!!!
Wrong Image Format for bootm command
ERROR: can't get kernel image!
VR9 #

I have tried going back and reinstalling the backup I made and going through the install procedure again. Lede seems to install without error messages but I get back to this same error when it tries to reboot.
Does anyone have a fix?

Try installing new openwrt image using

you can also get an original BT HH5a NAND image from the people here at the forum, to do a complete recovery, and start from scratch.

Thanks, have tried that opewrt image. May have to try a different NAND image from the one I made as backup