BT HH5A 2.4 GHz wireless not working in latest version plus some other stuff


Googling around I couldn't see anyone with my exact same problems so I thought I'd flag them up. The good news is I have workarounds.

So, hacked my 3rd BT Home Hub 5a. Went straight for 17.01.4 All went as expected to begin. This hub was to be a lab router (building a virtualisation lab and I want it to sit behind a router with VLANs and the like). Decided to use the WAN port as the uplink to my home network. It took me ages to get this working. I created a new VLAN and following the HH5A doc created a custom interface eth1.2. I couldn't get the interface to come up. Long story short, chose eth0.2 in LUCI and it worked straight away. Seems to make sense to me but all the documentation I read seems to refer to a custom interface eth1.2. Perhaps the docs need updating or something else is going on with my setup.

Second more puzzling problem. I created another VLAN for my lab and bridged the wireless interfaces to it. I then configured them and brought them up. However, only the 5GHz radio would come up. The 2.4 GHz persistently reported "wireless is disabled or not associated". Tried editting /etc/config/wireless using my two working hubs as templates. Tried wiping /etc/config/wireless and creating new with wifi config (as directed by wifi detect). Nothing happening. Noticed something in a log about firmware failing to load but Googling that didn't help. So I took the hub through the same steps as my previous two. I uploaded (downgraded to) 17.01.0-rc2 and bingo, I had both radios working. I then took the hub though 17.01.1, 17.01.2, 17.01.3 and finally back to 17.01.4. After each upgrade and including both radios functioned. Worth noting that when up/downgrading I chose to keep settings.

I'm guessing there is something in the earlier builds that isn't quite right in current. I hope to get another HH5A (I think they are great) so if the cause (assuming there is one and it isn't me) hasn't been found I'll go back from latest to a) confirm it wasn't a one off and b) see when things start/stop working.

You might consider opening a ticket...

Yes, I probably should but I'd like to confirm to myself that it's not me being daft and there is genuinely a bug.

Will get another HH5A and will start with 17.01.4 and how it goes. If I can reproduce the duff radio problem I'll raise a bug.

Good point...