BT FTTP Setup - vdsl modem needed?

Hello everyone!

I have got a decent netgear router which I am going to switch to openwrt. The problem is that it does not support pppoa connection which is requred to connect. Currently I use my ISP provided Smart Hub 2. Is my understanding correct that I can use BT Home Hub flushed to OpenWrt up to the most recent version as LEDE (which I assume has been fully incorporated) supported that several years ago?

Thank you for your help!

The term FTTP sadly doesn't answer this question, it merely implies that the fibre ends somewhere on your premises, how it goes on from there into the house is undefined.

Popular choices would be:

  • fibre
  • ethernet
  • (local) VDSL
  • modulated over coax (the TV cable)
  • something completely different (even ISDN or crappy analogue modems have been used for this in the past, e.g. OPAL)

This indeed suggests that your ISP is using VDSL to get into the house, which is a very common choice (at least for FTTB, fibre into the building (basement), using VDSL2 into the individal apartments).

We can't really answer this, you need to check what your ISP (respectively the fibre <--> VDSL converter they've buried somewhere) requires, the BT Home Hub 5 Type A 'only' supports simple vectoring (up to profile 17b, ~100 MBit/s) - but super-vectoring (profile 35b) is not possible with the lantiq chipset versions supported by OpenWrt. It would help if the OEM firmware on the Smart Hub 2 could clarify the currently used connection settings (keep in mind, the BTHub5 can do up to ~100-120 MBit/s (with its back hard against the wall), if you get more right now, the BTHub5 won't help you anyways).

1 Like

First thing is first let's find out if your on FTTC or FTTP/H.

Does your BT HomeHub connect to a phone socket (NTE5)or micro filter or does it connect to another device (GPON).

If the latter simply change PPPoA to PPPoE you will be fine it should work without issue.

If it's the former depending on your DSLAM your on will dictate which modem chipset you use. If your on an ECI DSLAM you use Infineon (Lantiq) if your on a Huawei DSLAM you use Broadcom.

Then you will also use PPPoE as well for that.

Example of GPON:

Example of NTE:


@solidus1983 @slh

Thank you for your replies!

The router I want to switch to is Netgear r7800.

As far as my setup let me add these details. I have 2 openreach devices in the storage room (one is exaclty as in @solidus1983 picture) and I believe fibre goes up to the apartment. Smart Hub 2 uses a normal net cable to connect its WAN port to the mounted device.

Sorry, did not get that. What is "Oppose"? Or can the new router somehow work without a modem in between of it and openreach devices?

Another thing that I tried to connect WAN port of Netgear router to LAN port of the Smart Hub 2 and it did not work. Is it supposed to work at all? I configured Smart Hub 2 LAN and Netgear LAN and DCHPs to different networks (i.e. masks). The Netgear WAN indicator light become white blinking with some pattern (not a random one as it would if it has connection) but there were no connectivity.

Thanks for help!

I am pretty sure Oppose is autocorrect for PPPoE, PPPoA will only ever work on a device that actually speaks ATM, so this will work with old ADSL, but VDSL/FTTB/FTTH all will NOT work with PPPoA at all (the oA stands for over ATM, and only ADSL still uses ATM on the link).

But as far sas I understand most ISPs in the UK will connect with either PPPoA or PPPoE, so just try to put your user name and password into your router's PPPoE configuration fields and see whether it will connect.

Just check BT GPON/ONT uses PPPoE.

Also yes the Oppose was the result of Autocorrect. I have corrected the post.


How can I check that? Does this device have a web or any other UI?

also here is the link I have got from BT support -

I tried that and that did not work. Also in this case WAN indicator had orange color and blinked with some non-random pattern.

If you have a box like that in your apartment, it is an ONT it has an Ethernet link to your router, there is definitely no DSL involved.

If your existing equipment connects to the building network with a phone jack (6 pin two wire, not RJ45) that is xDSL.

Right the BT Link you that was posted is for FTTC

All you need to do is on the Netgear is to flip it to PPPOE and in the username box put and in the password box put in bt that should then see you online without issues.

If not then it might be expecting and VLAN ID normally 101 but not sure how you send that via OpenWRT so a forum thread search might help.

Correct, as I mentioned normal Ethernet link is used.

I have not yet flashed Netgear to openwrt - just trying to make sure it works.

I have tried your suggestion before, but that did not work. Could it be the address issue/conflict with ONT device? What address does it use by default? I cannot see my BT Smart Hub or ONT device in traceroute output.

I will try the suggestion today and share the results.


I managed to bring my netgear online but only after I removed the default vlan

Can anyone please explain why did it help?

Many ISPs expect tagged VLANs on WAN, originally to share one physical connection for multiple services (VoIP phone, internet and IPTV on different VIDs) and theoretically also multiple ISPs sharing the same cabling. These days at least VoIP services usually share the main internet connection (so no longer using a dedicated VID), but IPTV is often still on its own VID.

The way you've configured that on the OEM firmware is correct, OpenWrt can do that just the same.

So we've now established that your GPON ONT (the fibre 'modem') provides you with plain ethernet on WAN, requiring VLANs with VID 101 and PPPoE - you can easily do that with any (supported) router running OpenWrt. The router should just be fast enough to cope with full WAN speed (which gets increasingly difficult above 200-300 MBit/s, requiring high-end devices).

1 Like

Thanks for the info. However let me clarify some bits. The default vlan id was 10 (no connection), then I changed it to 101 as on screenshot (no connection) then I removed this entry completely and router got the connection. In order to make the router work I disabled VLANs entirely

It's possible, I'm not familiar with the requirements of British ISPs - these settings solely depend on your ISP's requirements (and yes, you can mirror these settings with OpenWrt just as well).

1 Like

OpenWrt's default setting is no VLAN, so it should work right away for you.


So you are connecting your router via ethernet to the ONT/Modem? In that case it is well possible that the ONT/modem handled the VLAN tagging on its WAN side automatically, and it might not accept VLAN tags on its LAN side. Which would reconcile the documented use of VLAN 101 and the fact that configuring that on your router does not work...
I bring this up, because I see the same issue with my bridged modem...

I managed to install OpenWRT to my new router and switched to it completely. Thanks everyone for help!

Let me sum up and mark this post as a solution.

In order to connect a custom third-party router to BT (British Telecom) when using Optical Network Terminal (ONT) do the following:
Configure the router to connect with PPPoE
The username should be of the format No password is required, but if the router insists, use bt as the password

If router cannot bring WAN interface up try removing the default VLAN records.

Addtional info

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.