Bridging wlan to lan

Hi.

I have three networks (segregated subnets). lan, guest and devices.

There are four wlan networks:

radio0:

radio0_main
radio0_guest

radio1:

radio1_devices
radio1_guest

The lan interface is bridged with lan0,lan1,lan2, radio0_main ← So 3 lan ports and one wlan.
The guest interface is bridged with lan4, radio0_guest, radio1_guest ← 1 lan port and two wlan guest wifis.
Currently the devices interface is not bridged but is associated with radio1_devices.

Everything works as expected. My /etc/config/network for this is posted below.

The only change I want to make, is to now bridge the lan3 with radio_1_devices to devices interface.
When I do this, ipv4 dhcp is lost across all networks and the router is inaccessible and I need to rollback. I dont understand why. It's clear from the other bridged interfaces that it is possible to bridge LAN with WLAN, but I can't do it for my custom interface, devices.

Current network config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdAA:A9E:A9E::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option bridge_empty '1'
        option _turris_mode 'managed'
        option ipaddr '192.168.22.1'
        option ip6assign '60'
        option ifname 'lan0 lan1 lan2'

config interface 'wan'
        option ifname 'eth2'
        option macaddr 'XXXXXXX'
        option username 'XXX'
        option password 'XXXXXX'
        option ipaddr '192.168.13.2'
        option netmask '255.255.255.0'
        option gateway '192.168.13.1'
        option proto 'dhcp'
        option ipv6 '1'

config interface 'WAN6'
        option ifname 'eth2'
        option proto 'dhcpv6'
        option username 'XXXX'
        option password 'XXXXXX'
        option reqprefix 'auto'
        option reqaddress 'try'

config interface 'guest_turris'
        option enabled '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.111.222.1'
        option netmask '255.255.255.0'
        option bridge_empty '1'
        list ifname 'lan4'
        option ip6assign '64'

config interface 'vpn_turris'
        option enabled '1'
        option ifname 'tun_turris'
        option proto 'none'
        option auto '1'

config interface 'modem'
        option ifname 'eth2'
        option proto 'static'
        option ipaddr '192.168.13.2'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'devices'
        option proto 'static'
        option ipaddr '192.168.33.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

Adding the bridge settings and option ifname lan3 to interface devices breaks the network (no ipv4 DHCP on any network).

A few remarks. Modem interface conflicts with wan interface. You can delete the modem interface.
In lan and guest_turris you have option bridge_empty enabled, although it is not empty. What is the output of ubus call system board ?

Thanks for the reply.

The modem interface is used as a separate interface so I can route traffic to the modem's subnet. Essentially the modem is in bridge mode and the wan interface provides a route to the internet. The modem interface can route traffic to the .13.x subnet so I can connect to the bridged modem's web interface. All traffic to the wan is essentially sent to the internet.

I'm using a Turris Omnia:

{
	"kernel": "4.14.262",
	"hostname": "citadel",
	"system": "ARMv7 Processor rev 1 (v7l)",
	"model": "Turris Omnia",
	"board_name": "cznic,turris-omnia",
	"release": {
		"distribution": "TurrisOS",
		"version": "5.3.4",
		"revision": "r11395+90-974161d7f8",
		"target": "mvebu/cortexa9",
		"description": "TurrisOS 5.3.4 974161d7f891cc1a76c390258db2fac59a4d115c"
	}
}

I understood that, but still they have the same IP so they conflict. Delete the modem interface, it is not necessary, all traffic to the internet or the modem goes through wan anyway.

Regarding the Turris, it is running TurrisOS so you'd better ask in their forums as it is not easy for someone to help you reproduce the issue on an OpenWrt.

With an IP type connection on wan you shouldn't even need a separate interface to access the modem since wan is the default route for any IP unknown to the router.

In any case you'd use @wan to put a second IP onto the WAN port.

The syntax here looks like a hybrid of version 19 and DSA which I guess Turris uses. As @trendy said you need to ask there for specifics about this build.

OK, I've posted on the Turris forums also.

I tried to delete the modem interface as you suggest and when doing so I can no longer reach the modem's web interface. So it seems I do actually require this interface to route traffic to that subnet.