Bridger internet issues when roaming between multiple APs

I have posted this on github as well but i thought I'd post here to get better visibility with others using bridger. I have a MT6000 as my main router and 3 MT6000 as dumb APs. It seems something broken with bridger. I am having issues with the internet not working when I’m bouncing between multiple APs around the house, even though the AP shows I’m connected with a great signal. When I remove bridger from the dumb APs and turned WED off on all units, everything works perfectly. Fast roaming works great, and I don’t loose internet connectivity when I’m bouncing around the house. Been up weeks and no issues, but with Bridger installed on the dumb APs and WED enabled or disabled on all the units… it lasts 5-10 mins before I lose internet walking around the house. I also turned off fast roaming and that made no difference.

I am using snapshot r26775 on the main router, and on my dumb APs and was using Bridger 2024.04.22~40b1c5b6. WED is ON (all units) Kernel 6.6.35 with the default snapshot WIFI firmware on all MT6000. I am not alone in this issue as others have posted on the git link.

Hoping some powerful minds can help us resolve the issue.

thank you!

here is the github link: https://github.com/nbd168/bridger/issues/6

You need to ask on gl-inet’s support channels. They have heavily modified their form of OpenWrt and it is not the same as the official openwrt that we support here.

I am using vanilla openwrt (the latest snapshot) r26775 and Kernel 6.6.35

Oh, ok. I thought you meant the vendor firmware when you said “default.” Carry on!

1 Like

Sorry - I meant the default WIFI firmware that comes with the snapshot as there have been some new releases. Switching the WIFI firmware in the MT6000 makes no difference either on bridger performance

@nbd I know you’re super busy, but can we get your help with this (if possible)? Please let us know how we can help. If there is any information or any logs we can share. Thanks! Appreciate your contributions, time and support in the community!

see last 2 commits - roaming is fixed for soft offload.
is bridger alone at fault?

SFO and HFO are turned off on my dumb APs. I’m using the latest snapshots as of yesterday. Would these commits be in there already? I can try again, I had just tried a couple of weeks with latest snapshots and was still having issues on my dumb APs and Bridger.

It switches off soft offload for wifi devices. No impact for hardware offload aka wed.
https://www.kernel.org/doc/html/latest/networking/nf_flowtable.html#limitations

You can check presence of patch:
Edit /etc/config/firewall to add

config defaults
...
       option flow_offloading '1'
       # option flow_offloading_hw '1'

Run fw4 print | less and see that flowtable interface list has no wifi interfaces in it.

table inet fw4
flush table inet fw4
delete flowtable inet fw4 ft

table inet fw4 {
	#
	# Flowtable
	#

	flowtable ft {
		hook ingress priority 0;
		devices = { "eth1", "lan1", "lan2", "lan3", "lan4", "lan5", "phy
0-ap0", "phy0-ap1", "phy1-ap0", "phy1-ap1" };
		counter;
		flags offload;
	}


	#
	# Defines
	#

	define lan_devices = { "br-lan.10", "vpn" }
standard input

This is what i see. Also should i be doing this command on my Dumb APs or the main router? This is on my main router.

Quickpath is fixed (for upto 30s) between interfaces and destination mac addresses, so on every AP you expect roaming you should switch off hardware offload, check flowtable list, and if wifi devices are in there switch offload off completely.

should i enable software offloading on all my dumb APs?

in my current setup HFO and SFO are only enabled on my main router. They are completely disabled on my Dumb APs.

You need to verify that wifi interfaces are not in offload loop. If they indeed are there with soft offload you can copy fw4.uc from after https://github.com/openwrt/firewall4/commit/dfbcc1cd127c78fc61bb870d36d2512b571d223b to your device.
Problem will manifest on main router too - it will maintain packet destination interface and MAC for 30s after roaming happened thus losing packets destined for roamed device.
IPQ has no hardware offload in mainline, there is NSS build that enables it using proprietary engine.

1 Like

NAT part of offloads are essential for 7621 to reach gigabit consistently
Either way education here:

1 Like

I will try and report back soon. thanks for your help!

reference: how soft offload corrected looks:

        flowtable ft {
                hook ingress priority 0;
                devices = { "br-lan", "wan", "docker0" };
                counter;
        }

see no flags ... off

1 Like

so it seems to be reporting correctly with no flags. I will try with bridger and WED enabled on my Dumb APs with only SFO enabled on them and report back. thanks!

WED will not be enacted with soft offload.

I am trying to get WED enabled on my dumb APs, so that’s why I am using Bridger. Without Bridger everything works fine, that’s why I assume Bridger is the issue. It seems that even when I roam, with Bridger enabled the old ap still sends a keep alive the IP/MAC address to the main router when it shouldn’t. The internet only breaks though, i can still access the AP and the rest of the devices on the network. If I restart Bridger it will start working again.