Bridge works with physical devices, but not fully with interfaces

Hi all,

I've got a bridge configured with three VLANs (1, 2 and 100), configured as below:

I've then got an interface attached to the device exposed by the 'local' flag on one of the VLANs (bridge.100).

Somewhere on this network is a DHCP server which is verified to be working. Devices plugged into physical ports will receive the expected IP addresses, which implies the bridge is working. The internal interface (attached to bridge.100) though, will not receive an IP address. Whenever I assign a static IP address though, I CAN reach the interface through one of the physical ports, which tells me the interface is attached to the bridge, and communicating. However, when logged into a SSH session I cannot get it to ping any other device on the VLAN, even though the laptop attached to the router is able to reach those devices, through the same bridge.

The same goes for the other internal interfaces attached to the bridge.

To summarize:

  • bridge works, physical untagged and tagged ports can communicate
  • internal interface attached to a VLAN on the bridge doesn't receive a DHCP assignment
  • internal interface is reachable when assigned a static address, but isn't able to reach other devices on the network
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd84:a761:1090::/48'

config device
        option name 'lan2'

config device
        option name 'wan'

config interface 'management'
        option proto 'static'
        option ipaddr '192.168.1.3'
        option netmask '255.255.255.0'
        option device 'bridge.1'
        option gateway '192.168.1.1'

config device
        option type 'bridge'
        option name 'bridge'
        list ports 'extsw'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'
        option acceptlocal '1'

config bridge-vlan
        option device 'bridge'
        option vlan '1'
        list ports 'lan1:t'
        list ports 'lan2:u*'

config bridge-vlan
        option device 'bridge'
        option vlan '2'
        list ports 'lan1:t'
        list ports 'wan:u*'

config bridge-vlan
        option device 'bridge'
        option vlan '100'
        list ports 'extsw:u*'
        list ports 'lan1:t'
        list ports 'lan3:u*'
        list ports 'lan4:u*'

config device
        option name 'bridge.2'
        option type '8021q'
        option ifname 'bridge'
        option vid '2'
        option acceptlocal '1'

config device
        option name 'bridge.1'
        option type '8021q'
        option ifname 'bridge'
        option vid '1'
        option acceptlocal '1'

config interface 'wan'
        option device 'bridge.2'
        option proto 'none'

config device
        option name 'lan1'
        option acceptlocal '1'

config device
        option name 'wlan1'
        option acceptlocal '1'

config device
        option name 'wlan0'
        option acceptlocal '1'

config device
        option name 'eth1'

config interface 'users'
        option proto 'dhcp'
        option device 'bridge.100'

config device
        option name 'bridge.100'
        option type '8021q'
        option ifname 'bridge'
        option vid '100'
        option acceptlocal '1'

I'm hoping to get some advice on how to solve this issue.