Bridge passthrough LAN-to-WAN without loss Internet connectivity on router

I have a router with 2 ethernet ports, wifi, and cellular. I am using this as a sub-router inside my network connected to a main router. For this question I'm focused just on two ethernet ports. Normal configuration is that one port is the WAN (connected to the local router) and the second is LAN (providing DHCP to other devices). This mode works perfectly.

I'd like it to operate where the LAN is just a pass-through (switch) so a LAN connected device receives DHCP via the main router connected to the WAN port. The network file I created achieves this functionality, but I lose internet access on my router itself. I am unable to ping outside the local network when ssh'd onto the router. Is there something I'm missing in the network file to fix this? Note that I'm also using mwan3 to select which interface to use and mwan3 considers the interface 'lan' down.

My network file is below:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'apspt'
        option type 'bridge'
        option dns '8.8.8.8' 
        option proto 'static'
        option ipaddr '10.130.0.1'
        option netmask '255.255.255.0'
        option gateway '255.255.255.255'

config interface 'apspt2'
        option type 'bridge'
        option dns '8.8.8.8'
        option proto 'static'
        option ipaddr '10.130.5.1'
        option netmask '255.255.255.0'
        option gateway '255.255.255.255'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.0.175'
        option netmask '255.255.255.0'
        option gateway '255.255.255.255'
        option dns '8.8.8.8'
        option ifname 'eth0 eth1'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option hostname 'iobot-9B4A'
        option metric '40'

config interface 'wwan'
        option proto 'dhcp'
        option metric '50'
        option hostname 'iobot-9B4A'

config interface 'cell'
        option ifname 'ppp0'
        option proto '3g'
        option device '/dev/ttyACM2'
        option service 'umts'
        option metric '60'

Why this gateway? It looks really odd.

Yes. That does seem to be the issue. I fixed the gateway to be the router and the problem seems to have gone away. Thanks for the second set of eyes!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.