Bridge mode on FritzBox 3370

I'm struggling with bridge mode on a FritzBox 3370. Provider is Vodafone Germany with VDSL.
OpenWrt version is the latest snapshot. I don't need access from the local network, currently I'm using a serial connection. I found some older tutorials but I'm not sure if they are still valid:


but from what I read the interface is now dsl0 and I don't know what to do with
"config device 'ptm_dev'"
...

and other things referring to ptm*
Also I'm wondering where to set the vlan id and what to use for the switch configuration.
In principle I'm only going to use the DSL/WAN port and one of the LAN ports. Will the default firewall configuration work for the bridge mode? Any help appreciated :slight_smile:

I got pppoe working directly on the FritzBox. The only thing missing is how to configure bridging LAN to WAN (and maybe disabling access to the device from the local network) so that my other router does dial-up and the FritzBox only acts as modem. Some other thread also suggested to disable the firewall though I don't know if this is required. Current config is:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd6d:a67d:a9a7::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option xfer_mode 'ptm'
	option tone 'av'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '...'


config interface 'wan'
	option proto 'pppoe'
	option _orig_ifname 'ptm0'
	option _orig_bridge 'false'
	option ifname 'dsl0.7'
        option username '...'
	option password '...'
	option ipv6 'auto'

config device 'wan_dev'
	option name 'dsl0'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

Ok got it working finally. The only remaining issue is that I only get 20 mbit down and 2 mbit up. dsl_status also reports these values. Any ideas what to change to get my full speed (100/40 mbit) ?

For 100/40 MBit/s, you most likely will have to supply a vectoring enabled firmware (OpenWrt can only ship a non-vectoring firmware for licensing reasons), which means you most likely ended in a slow non-vectoring fallback profile.

With a vectoring firmware you may get up to a throughput of ~80-85 MBit/s, if you enable flow-offloading you might hit 100/40 MBit/s on average (assuming SMP is enabled (no FXS ports) for your device).

Thanks, where can I get this firmware?

You have to extract it from a firmware image: instructions.

Ok, I managed to extract the files with help of this thread:

I extracted the files from the latest FritzBox 3370 image. I also get a decent speed now.
How do I know if SMP is enabled or if I can use flow offloading? Using
option flow_offloading 1
in the firewall config did not work, nor did

uci set firewall.@defaults[0].flow_offloading=1; uci commit firewall