Bricked Xiaomi 4a Gigabit and broken bootloader

I have xiaomi 4a with openwrt and breed installed as bootloader. At some point I try to update the bootloader to the newer version but it looks like I miss some steps and got my xiaomi 4a bricked and broke the bootloader. :smiling_face_with_tear:

I try to connect via urt usb ttl but I have no clue:

Can someone provide me the SPI flash memory dump please, I planned to recover using ch341a prog tools.

Thanks in advance

Sure it's not just an incorrect serial port speed?

I don't know what exactly the port speed should be. I tried 115200, 9600, 57600 and still get the weird looking code as above. I doubt the uart usb ttl will works since the bootloader is broken, isn't it?

Check this out.

source: Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion


1 Like

Also check your ground connection. The bootloader is running if it is printing to the serial port. It's on your side that it becomes garbled.

1 Like

Thank you very much.

hmm, probably the connection is loose