Bricked tp link mr3420 v5.1 (EU)

trying to revert to OEM firmware since the router does not have the memory to install luci qmi packages that i need to run the huawei k5160 dongle , but when i try to restore oem it goes into a form of soft brick all light blinking like it`s china town copied the oem to the router via winscp then tried to run the bin via putty it is here where i get stuck neither of the following work dd if=orig.bin of=tplink.bin skip=257 bs=512 or mtd -e firmware -r write /tmp/tplink.bin firmware

more so i am willing to keep the openwrt if there is a way to make the k5160 dongle to work

Given you're using a mobile dongle, you may want to investigate ROOter which is derived from OpenWrt.

The latest version of Gargoyle (v1.14) is also derived from OpenWrt and also includes some support for mobile dongles, though not as comprehensively as ROOter. Gargoyle also has it's own user interface, while ROOter is still based on LuCI.

You should be able to use either firmware's sysupgrade images from OpenWrt's firmware flash function, but don't try and preserve configuration - each has too many customisations to the config files for that to be successful. The ROOter images for your device should definitely have all necessary modem drivers in the firmware; the Gargoyle images may not.

I have used Gargoyle on a TL-WR902ac v3 with Huawei Hi-link dongles (E3372 and E8372).


/root/tmp <> /tmp

in a worst case scenario, dd is also available on Windows.

i dont really get it the command dd should skip the first 257 and start at 512 to avoid the boot in the oem firmware ? if so then is there a way to delete this part of the bin file on my pc and then try again via tftp ?

Not sure how it's supposed to be flashed, but yes, you can do it on your PC.

It would have worked on you router too, if you'd stored the file in /tmp.

flashed the Rooter (for men :laughing:) at their page the huawei E3372 aka k1560 seems to be supported BUT doesnt show via PC its functional and working i am using it right now , altough the log file shows it

You'll have to take this up in the ROOter forum - WARNING: this is a single thread with over 1600 pages, so use the page navigation at the top or bottom of the page to get to the last page!

1 Like

The OEM firmware format is bit different. If you are trying to brick it, you may use some boot loader with web-interface for easier flashing.

If your dongle is with the stock firmware, it may start as a USB storage device, if the driver is not present over the host. Your device appears to be a Vodafone branded, so possibly there could be some issue with the usb_modeswitch configuration for this USB device ID, or it was not present over the previous firmware. "No Comm Ports" if being an error may mean that it was trying to start it in an unsupported mode.

i deleted the boot section 512 bytes from the oem bin file used tftp and managed to restore the oem , obviously no change the dongle does not show up , i dont have the knowledge to querry the dongle i know it`s using AT commands but i dont know how to start coms with him tried with putty but no success

then please mark this topic as solved and if you have questions about interaction with your modem - start a new topic

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.